Hello....recently acquired '94 e34 530i - BMW Forum - BimmerWerkz.com
New Members Check In come in say hello...

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-23-2008, 12:52 PM
n00b
 
Join Date: Oct 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hokiepolk is on a distinguished road
(Thread Starter)
Hello....recently acquired '94 e34 530i

New to forum...appears to be very active.

Have a few issues to resolve with the car.

1. Driver's seat not functioning (after wife moved it all the way forward)...could not drive it to work this morning. Saw on here it might be plastic connector immediately behind controls...but then saw that may not be true for e34. Was working fine with no issues...passenger side still works fine and all fuses check out good. Pretty sure its connector or wiring to switch...will look at tonite.

2. Suspension SOFT. I've acquired front struts to install. Will Align after that too. Will try front only first to see difference...may do rears later if they are soft...front's my main concern to start with. Need to get hands on spring compressor...local shops should have those on loan.

3. Plastic hinge point on rear of glove box broken (man, what a whack job design that is with those small clamps). Piece no where to be found...any ideas on repair or replace? Think I can rig up a reasonable solution that'll work.

4. Driver's door will lock, but not unlock with key except from passenger side of car. Feel/barely see a short dangling link pin hanging from the lock cylinder, but can't see where it attaches. Any pics or diagrams of correct linkage connect for this available...none in either of my two BMW repair manuals. Might have to tear open passenger door to try to feel for link and learn which direction it might have to go (assuming same as driver's side linkage).

Those are the main issues nagging me. Lots of little things to work on...some saggy headliner in places. Leather on driver's armrest gone down to foam (hello new leather armrest cover). Headrest mechanism makes noise, but no motion (saw info on torsion link shrink issue and how to fix). Couple little dings in body, nothing major. Mechanically, sound. Just going to try and knock out issues one by one and get it back in good shape.

Appreciate the board and look forward to participating.

Hokiepolk
'94 e34
~170k mi
hokiepolk is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 E34 530i Won't Start! Please Help! E34HartgeH5 5-Series (E12,E28, E34, E39, E60) 10 07-15-2013 02:37 PM
E34 530i Oil Line Replacement yt NYC 5-Series (E12,E28, E34, E39, E60) 1 05-02-2005 05:35 PM
I May Have Just Acquired An '84 318i... filter27e 3-Series (E21, E30) 9 04-08-2005 06:25 PM
95 530i (E34) Tire Pressures tezmanian 5-Series (E12,E28, E34, E39, E60) 1 12-05-2003 03:23 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome