Hello, my first E46 M3 SMG vert!!! - BMW Forum - BimmerWerkz.com
New Members Check In come in say hello...

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-25-2012, 01:13 AM
n00b
 
Join Date: May 2012
Location: new york
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mattb_lsbm3 is on a distinguished road
(Thread Starter)
Cool Hello, my first E46 M3 SMG vert!!!

Hi All,

I am now the very proud owner of my very first (previous car was a 1999 techno violet 5 speed m3 vert) E46 M3 vert Laguna Seca Blue, with black soft-top and black hardtop. Black Miro 19 rims, carbon fiber seibon hood w/ grills/ not sure what those things are called. Carbon fiber air splitter up front and cf air splitter in the back of car, and cf rear wing on trunk painted lsb. Also has two ten inch rockford fosgate subs in a sealed box w/ a decent amp. The car has all options, heated seats, front/back sensors,angel eye or halo front lights, gps navigation w/ 6 disk cd changer and a clean title w/ 117,xxx miles on it. I cleaned the interior really good like three times, cleaned the engine bay a few times and washed and waxed/buffed the whole thing out, man that took like 3 hours.

So far since owning it for about three weeks I have done the following:

- New rear tires - 275/30/19
- New front koni struts and alignment
- Oil Changed to redline 10w60
- New rear brake pads

Once I got the car back from some shop that did my struts, I took it over and dropped it off to an indy shop where the car been since about 3pm today 5/24/12, I had to take another day off tomorrow from work

Issue w/M3: When going about 30 mph - 40 mph, now it does not matter if I am in gear or out of gear, the car is wobbling from side to side, I can throttle out of this vibrating mode easily, but just want it fixed. Could be guibo/drivetrain rtabs, I am not sure?

Issue #2: When accelerating kinda fast or going fast through water, the car seems to be losing the rear end, seems to not want to go straight, even alignment and new front strut, issue still there. Could be guibo/drivetrain rtabs, I am not sure?

I bought the car not knowing it had issues, but hope can be fixed...I only test drove it myself. The lsb color is what made me buy it.

I plan on getting more engine maintenance out of the way then cf side mirrors and the cf csl trunk and new speakers to replace the old stock.

I will get pictures up once I get my car back from shop and wash it again.

Hope to hear some feedback from fellow member here

Thank you all,

Mattb_lsbm3

Last edited by mattb_lsbm3; 05-25-2012 at 01:40 AM.
mattb_lsbm3 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E36 Vert Issues XGiWiTHA323i 3-Series (E36) 7 02-27-2011 12:28 PM
Vert from holland wasted000 New Members Check In 3 10-24-2008 10:42 PM
NEW to community! vert problems also lol blk328ivert 3-Series (E36) 0 06-06-2008 05:39 AM
Took New pics of my 95 E36 Vert 325IConvertible Picture Showroom 2 06-12-2007 10:46 AM
My New '99 323 Vert SpooldUp Picture Showroom 0 08-01-2005 02:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome