Engine shaking problem e30 - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

New Members Check In come in say hello...

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-30-2008, 07:51 AM   #1 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
bimmer1990 is on a distinguished road
Engine shaking problem e30

My first post and need a bit of tech advice from anyone who may know.

Have a 1990 BMW 316i coupe. E30 shape with an M40 Engine
The thing is the engine seems to shake/vibrate in a cyclical way. It does this while driving and idling. The vibration can be felt through to the steering wheel and when siting in the driver seat too. The shaking/ vibration cycles through being steady for a second, then shaking for 1 to 1.5 seconds

I know that if I don't try sort it out know, I'll be selling a kidney to get it repaired later on.
I ain't the most clued up when it comes to engines, but I've made a start and checked a few things out, to tick off the list.

Have checked the rotor arm, distributor cap and ignition coil. They all seem in good condition. Have put in a second set of spark plugs but still the same cyclical shaking.
Have recently changed all the belts (timing, PAS and alternator). Also changed the gearbox/ transmission oil and changed the engine oil with to 5w40 synthetic oil.
Engine coolant leak was fixed and the coolant level has been constant for some time.
Had new engine and gearbox mounts put in about 8 months ago.

Not sure what else I can change myself.
Would appreciate any advice on what might be causing the problem.
Thanks!

Last edited by bimmer1990; 09-30-2008 at 07:58 AM. Reason: hit the wrong key, and posted to early
bimmer1990 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-30-2008, 09:00 AM   #2 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Sounds to me as if the timing is to far retarded or advanced, or you have the firing order incorrect as in 2 of the HT leads are on the wrong plugs.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 09-30-2008, 02:51 PM   #3 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
bimmer1990 is on a distinguished road
I'll check the HT leads again.
Also how do you go about adjusting the timing? or should i leave it for the garage to do?
I got the haynes manual, a pretty good web site that has colour pics and a step by step guide (Pelican Parts - Porsche Parts & BMW Parts - Automotive Parts and Accessories - Porsche & BMW) and time this weekend.

Thanks again for the info.
bimmer1990 is offline   Reply With Quote
Old 09-30-2008, 03:30 PM   #4 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
I dont beleve it would cycle if it was the cam timing or the Sparkplug lead mixed up... those would just cause it to run horrable....

Have you cleaned the ICV(Idle Control Valve)? WHy was the engine replaced BTW?
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 10-01-2008, 06:47 AM   #5 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
bimmer1990 is on a distinguished road
sorry, I mean't I recently changed the engine mounts and the gearbox mounts. Engine was fine, this shaking's just crept up and getting more and more noticeable.
Haven't tried cleaning the idle control valve. I'll give it a go this weekend, when I have another try and check a few other things.
Thought maybe because the tracking and wheel balance was out on the front wheels, that might have loosened something, but the engine still shakes cyclically even when idling.
I'll let you know if there's any improvement.

Thanks!
bimmer1990 is offline   Reply With Quote
Old 10-02-2008, 09:11 PM   #6 (permalink)
n00b
 
Join Date: Oct 2008
Car:
Posts: 4
Photos:
lowbuck2 is on a distinguished road
Im curious where it is idling at - and does the engine stall well below 800 or so.....
alpine may hit head-on with the IAC....
lowbuck2 is offline   Reply With Quote
Old 10-03-2008, 05:19 AM   #7 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
bimmer1990 is on a distinguished road
the engine idles at about 800 rpm and doesn't fall below that or stall. There's just a very noticeable shake coming from the engine that can be felt through the driver seat, steering wheel and in the general area where you'd sit.
still gotta check the Idle control valve tomorrow. Will let you all know if it solves the problem.
thanks again
bimmer1990 is offline   Reply With Quote
Old 10-04-2008, 12:08 PM   #8 (permalink)
n00b
 
Join Date: Aug 2005
Car:
Posts: 34
Photos:
bavarian is an unknown quantity at this point
hi there try cleaning the idle valve as they to tend to go.
bavarian is offline   Reply With Quote
Old 10-04-2008, 12:43 PM   #9 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
PCV valve springs to mind! ?
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 10-04-2008, 09:14 PM   #10 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
^ could be a vacuum leak of some sort... Check the intake boot and all vacuum line for crack... if any replace it!
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 528i Wheel and Front End Shaking Problem thedude2470 5-Series (E12,E28, E34, E39, E60) 10 12-18-2010 07:51 PM
my shaking problem: Lower control arm csrumber1 3-Series (E21, E30) 3 09-19-2006 10:02 PM
problem with my engine E 46 M3 M3 SPAIN M-Series (M1, M3, M5, M6) 3 06-27-2006 03:26 PM
Engine Shaking rhyk325i 3-Series (E36) 11 06-25-2004 10:20 PM
shaking problem socalguy 3-Series (E36) 16 06-03-2004 08:27 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:01 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.