BMW 528I, lazy starting & hesitation in acceleration - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

New Members Check In come in say hello...

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-09-2009, 11:42 PM   #1 (permalink)
n00b
 
Join Date: Jun 2009
Car:
Posts: 2
Photos:
h.hamed is on a distinguished road
BMW 528I, lazy starting & hesitation in acceleration

Hi all,
I have BMW 528i MODEL 2000, 90,000 km milage. I face a problem with acceleration during the second operation of the engine. This means that at the first operation during the day, no proplems at all and the car goes in excellent condition, I can drive and speed up as much as want. But when I switch it off for a while (minutes to 2 hours) and try to switch it on again, I face both lazy starting of the engine and hesitation in acceleration. It is not necessarily to face these problems in the 3rd operation. No fault codes given by the computer but I changed the fuel pump, air and fuel filters, timing chain, and checked both the plugs and fuel injectors. Still I have the same problem. Pls any ideas that help. By the way, the last time I checked the computer, it came up with a fault in air mass sensor. I think I have to replace it as the last chance. What do you think?
h.hamed is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-09-2009, 11:54 PM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
That would be a good start.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 06-13-2009, 02:21 PM   #3 (permalink)
n00b
 
Join Date: Jun 2009
Car:
Posts: 2
Photos:
h.hamed is on a distinguished road
Thanks to God, finaly the problem solved. it was the cam shaft sensor. Once replaced, everthing becomes excellent.
h.hamed is offline   Reply With Quote
Old 06-13-2009, 02:32 PM   #4 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Glad you got it sorted!
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 06-13-2009, 06:33 PM   #5 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
Cam position sensors are common issues....
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitation in acceleration onitsway 1,6,7,8 - Series and Mini Cooper 18 08-19-2012 05:53 PM
Can I change the Radio&Tape player in 1997 BMW 528i to a new Muti-Media Center? aeroxy Audio and Electronics 2 03-22-2009 05:08 PM
lazy starting 525tds bmnkyharris9 5-Series (E12,E28, E34, E39, E60) 4 10-06-2008 07:26 AM
Hesitation & Check Engine Light jek1955 3-Series (E36) 3 03-15-2005 08:04 PM
528i acceleration roblems par0thead151 5-Series (E12,E28, E34, E39, E60) 13 12-07-2003 04:22 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:02 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.