Problem with M5 3,8 (s38) engine, error codes - BMW Forum - BimmerWerkz.com
M-Series (M1, M3, M5, M6) General M-Series Discussion - If it does not fit into a more specific M Category above, please place it in here. In addition, previously archived M-Series discussion is located in this section.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-25-2009, 06:08 PM
n00b
 
Join Date: Aug 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
teigas is on a distinguished road
(Thread Starter)
Problem with M5 3,8 (s38) engine, error codes

I have a Bmw E30, that i have fitted a bmw m5, 3,8 (s38) engine in. The problem is that when it runs without any throttle at all, it does run up and down, and run unevenly.

We tried to read out error codes and got a
100: 100: Output Stage, Group 1

When i google it , i found a similiar code, but not the same number, we used a universial tool for reading error codes, perhaps this is the reason?

Anyway this was the info i found:

1218 Output Stage, Group 1 This code is stored if there is a short to B+ or Ground at the Output Amplifier Stage (Bank 1). Generally this code occurs with other defects. Causes may be a faulty Idle Speed Actuator, Injector Valves, Ignition Coil on Plug, Oxygen Sensor Heating Relay, Fuel Evaporation, Control Valve, Malfunction Indicator Lamp (MIL) and/or EKP Relay. Delete the code after examining for other faults. If the code recurs, delete code, then disconnect the DME for a minimum of 5 minutes to initiate a reset. Rerun car. If code recurs and no other defects are found the DME is most likely damaged and must be replaced. If the code does not recur and the engine runs properly, ignore.

If i read this correctly it can be a lot of things that is wrong? So the question is, what should i try first, and last? And any tips on how to get it to work correctly ? If i am to change all theese parts, it could be really expensive.

I also found 1 more error code, does not know what this one means?

26: SUPPLY VOLTAGE BATT. +

I anybody got a soulition or some tips i would be really greatfull.
teigas is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-25-2009, 06:11 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Arrow

Quote:
Originally Posted by teigas View Post
I have a Bmw E30, that i have fitted a bmw m5, 3,8 (s38) engine in. The problem is that when it runs without any throttle at all, it does run up and down, and run unevenly.

We tried to read out error codes and got a
100: 100: Output Stage, Group 1

When i google it , i found a similiar code, but not the same number, we used a universial tool for reading error codes, perhaps this is the reason?

Anyway this was the info i found:

1218 Output Stage, Group 1 This code is stored if there is a short to B+ or Ground at the Output Amplifier Stage (Bank 1). Generally this code occurs with other defects. Causes may be a faulty Idle Speed Actuator, Injector Valves, Ignition Coil on Plug, Oxygen Sensor Heating Relay, Fuel Evaporation, Control Valve, Malfunction Indicator Lamp (MIL) and/or EKP Relay. Delete the code after examining for other faults. If the code recurs, delete code, then disconnect the DME for a minimum of 5 minutes to initiate a reset. Rerun car. If code recurs and no other defects are found the DME is most likely damaged and must be replaced. If the code does not recur and the engine runs properly, ignore.

If i read this correctly it can be a lot of things that is wrong? So the question is, what should i try first, and last? And any tips on how to get it to work correctly ? If i am to change all theese parts, it could be really expensive.

I also found 1 more error code, does not know what this one means?

26: SUPPLY VOLTAGE BATT. +

I anybody got a soulition or some tips i would be really greatfull.
what year is the engine??? Is this a new install?... or was this car running ok previously??

what scanner was used and,

what are the codes you are reading from the scanner.

Last edited by darkhorse737; 08-25-2009 at 06:14 PM.
darkhorse737 is offline  
#3 (permalink) Old 08-25-2009, 06:14 PM
n00b
 
Join Date: Aug 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
teigas is on a distinguished road
(Thread Starter)
A place between 94 and 95, not really sure, but its there someplace, its from an BMw E34 M5. Hopes this helps.
teigas is offline  
#4 (permalink) Old 08-25-2009, 06:20 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Quote:
Originally Posted by teigas View Post
A place between 94 and 95, not really sure, but its there someplace, its from an BMw E34 M5. Hopes this helps.
PROBLEM!!!... there were no M5's produced in 94 & 95 i think... hmmm(unless what u have is a german spec. engine).

maybe 1993???

ANYWAYZ:
CODE 100 for BMW diagnostics is a loose connectiuon in one of the terminals of the wiring harness... recheck your work beginning from DME, and follow your wires down to the fuses, relays and sensors. check for corrosion at the terminals and make sure connectors are tight.

CODE26 only denotes that at 1 time the DME detected low voltage in the battery. Recharge battery and reconnect accordingly. You should be fine

Last edited by darkhorse737; 08-25-2009 at 06:32 PM.
darkhorse737 is offline  
#5 (permalink) Old 08-25-2009, 06:33 PM
n00b
 
Join Date: Aug 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
teigas is on a distinguished road
(Thread Starter)
I am not sure about what year the engine is from, all i know is that is from a E34 M5, its my friends car, and i am trying to help him out. It was bought used, so we are not sure if everything was working perfect. He has had another m5 engine before in another e30, that was running perfect, so we know that there is some problem with this, it just does not run perfect on low idle, just up and downs unevenly, and when he tries to hit the pedal to the medal, its not as good as it should be.

The scanners name it think stands on the picture i know attachted.

The engine is european.
teigas is offline  
#6 (permalink) Old 08-25-2009, 06:38 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Quote:
Originally Posted by teigas View Post
I am not sure about what year the engine is from, all i know is that is from a E34 M5, its my friends car, and i am trying to help him out. It was bought used, so we are not sure if everything was working perfect. He has had another m5 engine before in another e30, that was running perfect, so we know that there is some problem with this, it just does not run perfect on low idle, just up and downs unevenly, and when he tries to hit the pedal to the medal, its not as good as it should be.

The scanners name it think stands on the picture i know attachted.

The engine is european.
HA!! now, why did i suspect it was european

uneven idle - start from checking ICV, TPS, and airflow meter. those are the main parts responsible for idle.

Check also for difference in idle quality Engine COLD & engin WARM.

if there is.. let me know
darkhorse737 is offline  
#7 (permalink) Old 08-25-2009, 06:46 PM
n00b
 
Join Date: Aug 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
teigas is on a distinguished road
(Thread Starter)
The problem seems to come when it has runned for a little bit, and the tps have been checked, last time we checked it was ok.

ICV ? I am not sure what this is?

Did the error codes i posted in the picture give you any hints?
teigas is offline  
#8 (permalink) Old 08-25-2009, 06:53 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Red face

Quote:
Originally Posted by teigas View Post
The problem seems to come when it has runned for a little bit, and the tps have been checked, last time we checked it was ok.

ICV ? I am not sure what this is?

Did the error codes i posted in the picture give you any hints?
ICV = idle control valve... under the intake manifold. when that is dirty or connection is loose, idle is unstable.

error code - read my #4 post to you.
darkhorse737 is offline  
#9 (permalink) Old 08-25-2009, 06:59 PM
n00b
 
Join Date: Aug 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
teigas is on a distinguished road
(Thread Starter)
So you are saying check all cables from DME, and see if anything is bad?

DME is the brain i guess?

Also check the things you mentioned when talking about the idle?

The problem is also there when running just to let you know, it does not run clean, it also have some problems when he is driving in it, it does not run as good as i should, if you understand, i don`t know the correct word for this in english, so i hope you understand.

Could the problem be related to one of the 6 coils or injectors? Or could we rule them out?

Thanks for the great help so far.
teigas is offline  
#10 (permalink) Old 08-26-2009, 02:55 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Arrow

Quote:
Originally Posted by teigas View Post
So you are saying check all cables from DME, and see if anything is bad?

DME is the brain i guess?

Also check the things you mentioned when talking about the idle?

The problem is also there when running just to let you know, it does not run clean, it also have some problems when he is driving in it, it does not run as good as i should, if you understand, i don`t know the correct word for this in english, so i hope you understand.

Could the problem be related to one of the 6 coils or injectors? Or could we rule them out?

Thanks for the great help so far.
run the car maybe for 15minutes or so. if not driveable maybe at 1500rpm. when car cools down... pull out the spark plugs and tell me what you see. all 6 plugs.

wet or dry?
color... black, gray, dark brown, light brown or white...
condition of plug? good or replace if necessary
- i will trey to help you -

DME is the brain. that is correct.

Let me know....
darkhorse737 is offline  
#11 (permalink) Old 11-26-2009, 12:44 PM
n00b
 
Join Date: Nov 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
nelson.jones07 is on a distinguished road
You can find the correct code on BMW official website or in the manual of it. Also available with other websites. Search for them.

Nelson Jones
BMW Parts Wheels
BMW Headlights
BMW Accessories
nelson.jones07 is offline  
#12 (permalink) Old 03-13-2010, 02:02 PM
n00b
 
Join Date: Mar 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mikejohnson786 is on a distinguished road
You've covered the basics...
What do the plugs look like ?

I notice you state in your profile its a "eurospec M5..."

Our european models run on a minimum octane rating of 95.....

So I'd say 91-94 aint strong enough.....but that said, it depends if
the car has just started pinking....?

Is the timing chain / tensioner ok ??

BMW Headlights
mikejohnson786 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > M-Series (M1, M3, M5, M6)


Currently Active Users Viewing This Thread: 12 (0 members and 12 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Carsoft 6.5 error codes brettski FAQ's and DIY's 1 01-30-2010 04:04 AM
Error Codes Torque Test Forum 0 01-16-2006 01:19 AM
Motronic 1.0 and Error Codes??? 325eXTATIC 3-Series (E21, E30) 0 09-26-2005 01:19 PM
New Error Codes Hootie361 3-Series (E46, E90) 3 05-23-2005 01:18 PM
e34 m5 s38 engine and tranny mikempower Classifieds Sell & Buy 1 07-02-2004 06:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome