1997 M3 Radio - Only Get Static - BMW Forum - BimmerWerkz.com
M-Series (M1, M3, M5, M6) General M-Series Discussion - If it does not fit into a more specific M Category above, please place it in here. In addition, previously archived M-Series discussion is located in this section.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-29-2008, 07:52 PM
n00b
 
Join Date: Apr 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
m3sca is on a distinguished road
(Thread Starter)
1997 M3 Radio - Only Get Static

Hello, I have a 1997 M3. The factory-installed radio light died about a year ago, but the reception was still good. Over time, the reception became flaky: Good reception for a few minutes, then reception mixed with static for a few minutes, then several minutes of total silence. I bought an aftermarket 1997 M3 radio and installed it. The radio lights works and I can control the speakers, but I get only static (and barely one or two FM stations.) Any ideas? Thanks.
m3sca is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-31-2008, 10:34 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Lightbulb

Quote:
Originally Posted by m3sca View Post
Hello, I have a 1997 M3. The factory-installed radio light died about a year ago, but the reception was still good. Over time, the reception became flaky: Good reception for a few minutes, then reception mixed with static for a few minutes, then several minutes of total silence. I bought an aftermarket 1997 M3 radio and installed it. The radio lights works and I can control the speakers, but I get only static (and barely one or two FM stations.) Any ideas? Thanks.
antenna not connected ;-) OR, maybe they sold you a dud? :-(
darkhorse737 is offline  
#3 (permalink) Old 06-02-2008, 12:36 AM
n00b
 
Join Date: Apr 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
m3sca is on a distinguished road
(Thread Starter)
Thanks for the response. I actually turned in the used radio I bought and they sent me another one - still the same. I don't think it's the radio. I checked the antenna connections at the c-pillars and they look tight. I'm stymied!
m3sca is offline  
#4 (permalink) Old 06-02-2008, 12:39 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
nooo.. not at the c-pillars.

when u install the radio, the antenna plug tht connects behind the radio itself tends to jump out. make sure it's a snug fit

make sure u have good ground too. reception relies on a good ground to work ;-)

Last edited by darkhorse737; 06-02-2008 at 12:44 AM.
darkhorse737 is offline  
#5 (permalink) Old 08-10-2008, 06:30 AM
n00b
 
krause107's Avatar
 
Join Date: Jul 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
krause107 is on a distinguished road
I'm having a similar problem. Which wire(s) are grounds and what does the antenna plug look like?
Thanks.
krause107 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > M-Series (M1, M3, M5, M6)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 528i radio problems BMRBABE42 Audio and Electronics 16 06-05-2009 11:08 AM
Rear Defrost causes static on Radio dedahed 5-Series (E12,E28, E34, E39, E60) 1 09-24-2005 11:57 AM
Radio Static ghannanlt1 3-Series (E46, E90) 4 05-03-2005 03:16 PM
1997 328i Radio/cassette Player Styles5001 Audio and Electronics 1 01-23-2005 03:10 PM
1997 Radio iracema1 5-Series (E12,E28, E34, E39, E60) 1 12-16-2004 04:52 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome