radio and speaker issues - BMW Forum - BimmerWerkz.com
Audio and Electronics The place to go to discuss sound systems and show off your I.C.E. along with security systems and radar detectors too!

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-24-2009, 06:30 PM
n00b
 
Join Date: Feb 2009
Location: wisconsin
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
nedmanders is on a distinguished road
(Thread Starter)
Question radio and speaker issues

I have the factory stereo and speakers(I think the speakers are factory, my car is an 87 and I got it a couple weeks ago so they could be aftermarket but the radio isn't cus I had to call the dealership for the code for it)

For one, the speakers work off and on. When they work they sound good, but they don't always work. There is also crackling noise whenever I adjust the volume. As for the radio, I think the antenna sux cus I get perfect sound from my mp3 player but when I have to listen to just the radio(if I have no time to hook up the player) it cuts in and out, almost like the reception isn't so great.

How do I check for where the loose connection is? I don't even know where to start and I am not big on audio systems, I am pretty clueless when it comes to that sort of stuff.
nedmanders is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-24-2009, 09:32 PM
da_administrator
 
da_bull's Avatar
 
Join Date: Jan 2005
Location: Mooooossouri
Posts: 4,840
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute
Send a message via MSN to da_bull
If the car has ever been painted, its a good bet that the antenna isnt grounded correctly. Check where the antenna meets the bottom of the fender for a good ground. Tune the radio to a strong AM station. If you cant pick up AM, more than likely your antenna is shot and needs replaced. If you can, it may be the radio. You have to realize you are dealing with 25+ year old technology.

On the crackling noise, 20 year old speakers are probably shot, even its just one, it may make the head unit wig out and not supply proper voltage to the rest of the speakers. I'd start there. If you need any further assistance, lemme know. Good luck...



-There are 10 kinds of people. Those who understand binary, and those who do not.

-If we ever forget that we are One Nation Under God, then we will be a nation gone under...Ronald Reagan
da_bull is offline  
#3 (permalink) Old 03-19-2011, 11:00 AM
n00b
 
Join Date: Mar 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
davis123 is on a distinguished road
If you can hear in the speakers a crackling noise if it is always then i would suggest you to replace the speakers. it must have gone fault.
davis123 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > General Category > Audio and Electronics


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
radio issues thetallwun 5-Series (E12,E28, E34, E39, E60) 17 03-16-2009 02:57 PM
radio issues thetallwun 5-Series (E12,E28, E34, E39, E60) 0 01-18-2009 01:34 PM
6 or 10 speaker...? RexKing86 Audio and Electronics 1 05-17-2006 06:12 AM
Need Radio Code For 1992 Business Radio danger450 3-Series (E36) 5 03-07-2005 12:35 PM
1992 325i OBC and Radio / Speaker Problems bosoxfan78 3-Series (E36) 4 02-27-2004 11:04 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome