amp troubles - BMW Forum - BimmerWerkz.com
Audio and Electronics The place to go to discuss sound systems and show off your I.C.E. along with security systems and radar detectors too!

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-22-2003, 07:45 PM
Defector
 
El Presidente's Avatar
 
Join Date: Dec 2002
Location: Long Island
Posts: 5,973
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
El Presidente is an unknown quantity at this point
Send a message via AIM to El Presidente
(Thread Starter)
Yesterday my amp started acting funky.

At first the fuse on the battery blew. I replaced it today only for it to blow again 5 minutes later. After replacing it again, with the same result, I began to wonder. Also, after the second fuse, the amp would power up but the subs wouldn't fire. What's wrong and how do I fix?

<span style='color:gray'><span style='font-family:Courier'>1995 e36 3 Series RIP
1999 e46 3 Series BURN IN HELL
2000 MR-S Roadster= Current</span></span>
El Presidente is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > General Category > Audio and Electronics


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
5 series head unit to amp question. Non DSP greenwave 5-Series (E12,E28, E34, E39, E60) 6 06-28-2007 10:23 PM
For sale 12" Apline Speaker and 1400 Watt Amp scottm3 Audio/Miscellaneous Auto Parts 4 03-31-2006 09:53 PM
AMP Power cable! 316i e36 94 Butterfingers Audio and Electronics 1 10-09-2005 08:44 PM
How do you install amp and subs to a stock headunit? t5sesco Audio and Electronics 2 09-16-2005 01:26 AM
328 Si Turn Signal Troubles stuartwoodring@msn.com 3-Series (E36) 2 02-08-2005 10:11 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome