What's The Problem???? - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-13-2005, 10:56 PM
n00b
 
Join Date: Sep 2004
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
blacknite is an unknown quantity at this point
(Thread Starter)
Unhappy

i have a 98 528iA sport 35k and i never had any problems with it until last week. it all started with the airbag light coming on. one time i was on my way to work and i was going on a bumpy road and i noticed my airbag light came on and turned back off when i ran over a lil hole. since then sometimes when i turn the car on it lights up and other times doesn't. since last week the light has been turned on all the time but it's weird because when i turn the key to the second position the airbag light goes on and off like there is a bad connection but when i turn on the car it stays on. The same situatuion happened with my streering wheel buttons(radio controls, cruisecontrol) the buttons don't work at all and the cluster light inside the buttons when i turn on the headlight go on and off when i go over a lil bump. i checked all the fuses and umpluged the battery already but it didn't do anything. I been think that maybe it could be the ignition switch (guess) because last night when i was coming home from work i put in the key turned to the 2sc position and waited for the steering wheel to come down and some of the lights turn off and then started the car, and guess what?? the airbag light was off the buttons and the cluster light inside the buttons were working and i was all happy because it fixed it self until this morning the light came back on and the buttons didn't work again. Sometimes i think the car has a mind of it's own. Does any body know what might fix the problem or what's causing it? i hope that it's not a major problem.
blacknite is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-13-2005, 11:33 PM
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Posts: 1,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute
most likely faulty ignition switch (electrical portion) search thru old posts ...several posts on this.

DT

DT




Dirty_Tool is offline  
#3 (permalink) Old 02-24-2005, 05:42 AM
n00b
 
Join Date: Feb 2005
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
JJ47 is an unknown quantity at this point
Quote:
Originally posted by blacknite@Jan 14 2005, 03:56 PM
i have a 98 528iA sport 35k and i never had any problems with it until last week. it all started with the airbag light coming on. one time i was on my way to work and i was going on a bumpy road and i noticed my airbag light came on and turned back off when i ran over a lil hole. since then sometimes when i turn the car on it lights up and other times doesn't. since last week the light has been turned on all the time but it's weird because when i turn the key to the second position the airbag light goes on and off like there is a bad connection but when i turn on the car it stays on. The same situatuion happened with my streering wheel buttons(radio controls, cruisecontrol) the buttons don't work at all and the cluster light inside the buttons when i turn on the headlight go on and off when i go over a lil bump. i checked all the fuses and umpluged the battery already but it didn't do anything. I been think that maybe it could be the ignition switch (guess) because last night when i was coming home from work i put in the key turned to the 2sc position and waited for the steering wheel to come down and some of the lights turn off and then started the car, and guess what?? the airbag light was off the buttons and the cluster light inside the buttons were working and i was all happy because it fixed it self until this morning the light came back on and the buttons didn't work again. Sometimes i think the car has a mind of it's own. Does any body know what might fix the problem or what's causing it? i hope that it's not a major problem. :dunno
[snapback]271189[/snapback]
JJ47 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Idle / Misfire / Cutting out makdolby 3-Series (E36) 12 02-05-2012 07:57 AM
528i Alarm Problem Xero 5-Series (E12,E28, E34, E39, E60) 5 01-03-2011 01:16 PM
Smg Problem On 330i johanfunsale 3-Series (E46, E90) 0 02-28-2005 07:33 AM
Alpine 9835 Fm Tuner Problem ultraviolet353 Audio and Electronics 7 09-22-2004 11:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome