Weird Electrical Problem - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-25-2008, 01:11 AM
n00b
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hypnotised is on a distinguished road
(Thread Starter)
Weird Electrical Problem

Today, all of a sudden, my turn signals, horn and windshield wipers would no longer work, AT ALL. I checked all the fuses, and they were all intact. Now I'm stumped.
Everything worked fine minutes earlier.
Any clues on this one?

'87 535i

Tom B.
Hypnotised is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-25-2008, 11:19 AM
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Posts: 3,325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough
Garage
Did you check them with a 12v test light or did you do a visiual, because sometimes the fuse can be open on the end of the fuse housing.........& could be hard too see!
johnny,

______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109
johnnyBgood is offline  
#3 (permalink) Old 08-25-2008, 01:56 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Cool

my 2 cents worth...

follow the cluster of wires that run down the steering column.... one of the connectors may have come loose ;-)

then.. asdie from just checking fuses... check whether there is actual 12volts at each terminal of the fuse. if none, then trace ur electricity upstream

Good luck to u
darkhorse737 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problem e30bmwes 3-Series (E21, E30) 1 10-02-2007 11:15 PM
Weird Electrical Problem thekid 3-Series (E36) 7 11-05-2005 07:13 PM
Electrical Problem Black318IS 3-Series (E36) 1 12-10-2004 10:31 PM
Electrical problem? EricW 3-Series (E36) 1 08-12-2004 03:10 PM
Electrical Problem mysan325i 3-Series (E21, E30) 1 03-28-2004 10:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome