Trans Program Code,is This Bad - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-05-2009, 07:43 PM
n00b
 
Join Date: Feb 2009
Location: LAVERGNE TENNESSEE
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95tanbimmer540 is on a distinguished road
(Thread Starter)
Trans Program Code,is This Bad

PLEASE HELP... I HAVE A 95 BMW 540I. 220,000 MILES. RUNS GOOD..TRANS PROGRAM INDICATOR CAME ON AT RED LIGHT, TRANNY WENT INTO SAFE MODE. MADE IT HOME, LET COOL OFF, IT STARTED AND DROVE FINE FOR THREE DAYS. TRANS PROGRAM INDICATOR CAME ON AGAIN BUT RAN FINE THIS TIME.HAD CODES PULLED...152,98 ENG INTERVENTION....153,99 SOMETHING LOAD SIGNAL (CANT READ WRITING)....100,65 OR 100,64 SPEED MONITORING. ARE THESE CODES BAD, IS MY TRANNY GOING OUT. OR CAN IT BE SOMETHING SIMPLE. IF ANY ONE CAN HELP PLEASE LET ME KNOW...THANKS..
95tanbimmer540 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-06-2009, 06:34 PM
Neutral Member
 
Join Date: Aug 2008
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MADDOUG is on a distinguished road
I'm no expert but I would guess the speed sensor on the diff,the ecu relys on this to get the vehicle speed to compute gear changes (speed versus engine rpm plus throttle position plus gear selected) ie working out the load as to how your driving and changing gear accordingly if that makes any sense .The 'load signal' and 'speed monitoring' are confused so 'engine intervention' comes up as well,eng intervention probably being a fail safe limp mode.The sign of a dodgy speed sensor is the wipers only work in fast speed and no speedo working.I may be completely wrong but thats how it comes across to me,and the fact the fault comes and goes.
MADDOUG is offline  
#3 (permalink) Old 02-06-2009, 07:18 PM
n00b
 
Join Date: Feb 2009
Location: LAVERGNE TENNESSEE
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95tanbimmer540 is on a distinguished road
(Thread Starter)
Thanks For The Input. I Was Worried About My Tranny.
95tanbimmer540 is offline  
#4 (permalink) Old 02-06-2009, 07:41 PM
n00b
 
Join Date: Feb 2009
Location: LAVERGNE TENNESSEE
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95tanbimmer540 is on a distinguished road
(Thread Starter)
Where Is The Speed Sensor Located. Is It An Easy Fix
95tanbimmer540 is offline  
#5 (permalink) Old 02-07-2009, 05:34 AM
Neutral Member
 
Join Date: Aug 2008
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MADDOUG is on a distinguished road
BMW E34 Website This guide explains the removal of it and more important what tools to use to save climbing out from under the car every five minutes to get more that will fit and do the job.Get a few more opinions on the fault before you go under the car and start replacing parts as I well may be completely wrong.But if it occurs again and you have no slow speed/intermittant on the wipers and no speedo reading then the speed sensor or the wiring to it is at fault.It's an easy but awkward fix,depending if you have an overhead lift or are working on the floor.
MADDOUG is offline  
#6 (permalink) Old 02-07-2009, 05:36 AM
Neutral Member
 
Join Date: Aug 2008
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MADDOUG is on a distinguished road
The link does not mention trans program light on, only the speedo and wipers because it is a link to show how to replace only.Do a google search for autobox trans program/speed sensor and lots of info is available.
MADDOUG is offline  
#7 (permalink) Old 09-02-2009, 06:06 PM
n00b
 
Join Date: Sep 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hyperband is on a distinguished road
car dies when i push on gas what can i do?

I have a 95 540i bmw, i was driving on the freeway and all of a sudden my car looses power and idle like it wants to die. it starts sometimes and just idle like its going to die and if i hit the gas it dies. i thought my fuel filter was clogged up so i went ahead and changed it but didnt work. someone mention to me that it might have went into limp mode since i was driving a little to fast. please someone help. any pointers would greatly aprreciated.
hyperband is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans Program camper1159 5-Series (E12,E28, E34, E39, E60) 1 04-10-2009 09:38 PM
Trans Program On 95 540i 95tanbimmer540 5-Series (E12,E28, E34, E39, E60) 0 02-04-2009 06:55 PM
e-34 Trans Program Question 4-BMW's 5-Series (E12,E28, E34, E39, E60) 0 11-05-2008 04:23 PM
Trans Program Bunny Capricorn 5-Series (E12,E28, E34, E39, E60) 1 04-12-2005 08:15 AM
Trans program Hoopty 5-Series (E12,E28, E34, E39, E60) 7 01-04-2004 04:25 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome