Trans Failsafe Prog -- Now dead Battery -- What is going on? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-10-2009, 01:33 AM   #1 (permalink)
n00b
 
Join Date: Nov 2009
Location: Los Gatos, Ca
Car: 2001 540i
Posts: 2
Photos:
morganlopez is on a distinguished road
Trans Failsafe Prog -- Now dead Battery -- What is going on?

Day 1: I started my 2001 540i in the morning Trans fail safe error came on along with other dash lights. I drove it about 3 miles (using only 3 gear apparently). I parked the car for an hour. It started fine and drove fine but the battery light was now on. I drove it 3-4miles and parked it.

Day two: I drove the car 5 miles to the store. The battery light was on, the car ran fine. At the end of my trip the radio signal got weak, the interior lights got din and the windows closed slowly.

Day 3: Car will not not start. Interior lights come on but it will not turn over.

Does anybody have an idea of what is going on? I am thinking my alternator or battery are having problems. Should I be worried about the transmission?

What should I expect when I take it to a mechanic.

Any input would help. Thank you very much.
morganlopez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2009, 03:21 AM   #2 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
New battery by the sounds of it would be a good start, as its probably the original which would make it approx 8+yrs old......
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 11-10-2009, 03:30 PM   #3 (permalink)
Neutral Member
 
Join Date: Aug 2008
Car:
Posts: 66
Photos:
MADDOUG is on a distinguished road
Would not be worried about transmission.

Low system voltage ie duff battery always causes weird problems like this.

When you drove the car after parked for an hour the trans prog was gone because the battery had charged.

Anything can cause trans prog to flash up not just gearbox problems,ie an engine sensor will cause ecu to flash it up,its the ecu's way of protecting the car from being driven with a fault that could damage it.

So the ecu see's low system voltage or it just does not have enough power to compute properly so shuts car down to limp mode to protect it.
MADDOUG is offline   Reply With Quote
Old 11-10-2009, 03:39 PM   #4 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
aMy 740 came up with a transfail safe error right before the Batterey died i think a new battery would solve it
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 11-10-2009, 11:27 PM   #5 (permalink)
n00b
 
Join Date: Nov 2009
Location: Los Gatos, Ca
Car: 2001 540i
Posts: 2
Photos:
morganlopez is on a distinguished road
Thank you all for the advice. Thank you, Thank you.

I had the battery tested today and it is fine. After it was charged I reinstalled it in the car and it started right up. The red battery light is still on and not all electronics are working properly (radio). I disconnected the battery while the car was running, it died instantly. Is this sounding like any alternator problem. Could it be something else?

Thank you so very much for helping me with this.
morganlopez is offline   Reply With Quote
Old 11-11-2009, 06:04 AM   #6 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
That does sound like your alt is shot....
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 11-11-2009, 12:53 PM   #7 (permalink)
n00b
 
Join Date: Nov 2009
Location: Rangely co.
Car: 94 bmw 540i , 81 bmw 320is Turbo
Posts: 19
Photos:
e34lvr23 is on a distinguished road
Send a message via Yahoo to e34lvr23
i'm not sure if the newer 540i's have the fuseable link but i'd check that also!
e34lvr23 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"TRANS. FAILSAFE PROG" Oh $#!&, now what? ///Matt 5-Series (E12,E28, E34, E39, E60) 14 07-24-2008 06:42 PM
E34 trans prog problem exacerbated electronblue 5-Series (E12,E28, E34, E39, E60) 5 03-02-2006 10:07 PM
Please Help Trans prog Error 1989 E32 6cyl smudger395 1,6,7,8 - Series and Mini Cooper 0 09-29-2005 06:35 PM
"trans Failsafe Prog" Error Message bigmo1 Bimmer Talk/Motorsports Talk 0 04-03-2005 12:12 PM
TRANS. Failsafe Mode? E38 Pe!pe! 1,6,7,8 - Series and Mini Cooper 4 07-15-2004 10:57 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:13 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.