Tach Out - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-12-2005, 12:32 PM
n00b
 
Join Date: Mar 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
520i is an unknown quantity at this point
(Thread Starter)
Hi, i have a 90 520i with a little over 60k miles. Recently i noticed that the tachometer stopped workin, dropped to 0rpm and also the fuel consumption needle isnt workin as well. The inspection light is goin off but havent had time to take it to the shop and wont have any time for a while. The car runs great other than the tach and fuel consumption gage not workin. Before it completely gave out, it would ocasionally come on and then drop back to 0 and now hasnt moved for a couple of weeks. I am wondering if it might be a lose wire or something similar because just a visit to the shop to figure out what hte problem is will be costly. Any ideas greatly appreciated. Thanks.
520i is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-12-2005, 04:50 PM
n00b
 
Join Date: Mar 2005
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
doogie is an unknown quantity at this point
I've got an 89 520i (although it has 145k on it!)

The tach problem is either due to faulty batteries on the SI board or faulty capacitors. I've got the same problem, pulled the cluster and found that one of the batteries was totally dead, I've ended up running some wires from the points on the board to an external battery connector with new nicads in it, but I'm still having problems (at the moment if I disconnect the car battery, reconnect and start the engine, the tach works until I switch the engine off, then it doesn't work again till I next d/c the battery!) - I don't know wether it's dodgy wiring/ soldering or whether I need to do the capacitors as well.
doogie is offline  
#3 (permalink) Old 03-12-2005, 05:17 PM
You Can Has A Custom Title!!
 
CiscoKid's Avatar
 
Join Date: Apr 2004
Location: South Jersey, USA
Posts: 2,195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CiscoKid is an unknown quantity at this point
Send a message via AIM to CiscoKid
does the cluster lights and spedo worK?

CiscoKid is offline  
#4 (permalink) Old 03-13-2005, 04:20 AM
n00b
 
Join Date: Mar 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
520i is an unknown quantity at this point
(Thread Starter)
ok thanks for yalls help so far. The speedo and all the lights work in the dash, even the tach lights. I will try disconnecting the battery and the firin it up and see if it comes on.
520i is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tach Still Not Working yamaha405 3-Series (E21, E30) 8 02-15-2005 03:34 PM
Tach Problem With E28 islandbimmer 5-Series (E12,E28, E34, E39, E60) 0 11-25-2004 07:53 PM
Diag codes in tach? seandaly 3-Series (E21, E30) 9 08-24-2004 03:39 AM
Tach Bulb Replacement ramsey_5 3-Series (E21, E30) 5 07-29-2004 05:27 PM
Tach and hood sensor wire SiGmA_X 3-Series (E36) 0 07-08-2004 03:13 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome