Stereo Problem Solved! - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-03-2004, 10:41 AM
n00b
 
jeppcharts's Avatar
 
Join Date: Apr 2004
Location: Indianapolis, IN
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeppcharts is an unknown quantity at this point
Send a message via MSN to jeppcharts
(Thread Starter)
Several months ago I posted a topic complaining about the lack of bass response in my '97 528i and asked about installing a sub-woofer. I got many excellent responses, but all required me to invest between $350-$600 dollars. So I did my usual thing: I procrastinated. Meanwhile, my father-in-law (after driving my car) decided he had to have one for himself. He arrived at my house the other day with his identical '97 528i. He commented on how good his stereo sounded which made me get in and have a listen. HMMMM.... After hearing it and confirming his observation, I decided to disassemble the rear deck of my car and see what I could see. Lo and behold, the entire sub-woofer section was disconnected. I reconnected the large connector to the box and had instant bass. I bought the car from my sister who had bought it new and she said the stereo always sounded the same making me think that BMW just forgot to connect it. I wonder who else out there has sufferd this same problem.

R. Eric Dawson
'02 X5, '97 528i, '03 Z4
Member BMW CCA
jeppcharts is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-21-2004, 11:33 PM
n00b
 
Join Date: Jun 2004
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
huge534 is an unknown quantity at this point
Quote:
Originally posted by jeppcharts@Sep 3 2004, 08:41 AM
Several months ago I posted a topic complaining about the lack of bass response in my '97 528i and asked about installing a sub-woofer. I got many excellent responses, but all required me to invest between $350-$600 dollars. So I did my usual thing: I procrastinated. Meanwhile, my father-in-law (after driving my car) decided he had to have one for himself. He arrived at my house the other day with his identical '97 528i. He commented on how good his stereo sounded which made me get in and have a listen. HMMMM.... After hearing it and confirming his observation, I decided to disassemble the rear deck of my car and see what I could see. Lo and behold, the entire sub-woofer section was disconnected. I reconnected the large connector to the box and had instant bass. I bought the car from my sister who had bought it new and she said the stereo always sounded the same making me think that BMW just forgot to connect it. I wonder who else out there has sufferd this same problem.
[snapback]179550[/snapback]
where exactly is this subwoofer please let me.
huge534 is offline  
#3 (permalink) Old 09-22-2004, 05:27 AM
5th Gear Member
 
Join Date: Jul 2004
Posts: 1,028
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BeelZibub is an unknown quantity at this point
Quote:
Originally posted by huge534+Sep 22 2004, 04:33 AM--><div class='quotetop'>QUOTE(huge534 @ Sep 22 2004, 04:33 AM)</div><div class='quotemain'><!--QuoteBegin-jeppcharts@Sep 3 2004, 08:41 AM
Several months ago I posted a topic complaining about the lack of bass response in my '97 528i and asked about installing a sub-woofer.* I got many excellent responses, but all required me to invest between $350-$600 dollars.* So I did my usual thing: I procrastinated.* Meanwhile, my father-in-law (after driving my car)* decided he had to have one for himself.* He arrived at my house the other day with his identical '97 528i.* He commented on how good his stereo sounded which made me get in and have a listen.* HMMMM....* * * * After hearing it and confirming his observation, I decided to disassemble the rear deck of my car and see what I could see.* Lo and behold, the entire sub-woofer section was disconnected.* I reconnected the large connector to the box and had instant bass.* I bought the car from my sister who had bought it new and she said the stereo always sounded the same making me think that BMW just forgot to connect it.* I wonder who else out there has sufferd this same problem.
[snapback]179550[/snapback]
where exactly is this subwoofer please let me.
[snapback]196494[/snapback]


There isn't one (as far as I'm aware) - Just that the rear speakers handle most of the bass, but not all, also they handle the midrange too. So there isn't a dedicated sub woofer at all.
[/b][/quote]
BeelZibub is offline  
#4 (permalink) Old 09-22-2004, 06:13 PM
5th Gear Member
 
Join Date: May 2004
Posts: 1,414
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
d3ity will become famous soon enough d3ity will become famous soon enough
BMW's do have subwoofers

My e34 has them in the kickpanels and somewhere in the back...

Havent located the other one or two, but these are definatley standalone component woofers

<iframe src="http://gamercard.xbox.com/TiddlyPlatypus.card" scrolling="no" frameBorder="0" height="140" width="204">Put your gamertag here too.</iframe>
d3ity is offline  
#5 (permalink) Old 09-23-2004, 03:51 AM
5th Gear Member
 
Join Date: Jul 2004
Posts: 1,028
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BeelZibub is an unknown quantity at this point
So if you turned the BASS completely off these speakers wouldn't make a sound??? - if not they are dedicated BASS woofers or else they are a midrange/bass speaker - I checked mine, turn the bass right off and they still pump out plenty of sound. They may be designed to handle plemty of BASS but that doesn't make them a sub woofer.
BeelZibub is offline  
#6 (permalink) Old 09-24-2004, 10:32 PM
1st Gear Member
 
crackerkorean's Avatar
 
Join Date: Jun 2004
Location: ATL
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
crackerkorean is an unknown quantity at this point
Send a message via AIM to crackerkorean Send a message via Yahoo to crackerkorean
Does your car have DSS? If so it has two dedicated 5 1/4" subs under the read deck. Look for a DSS button on your MID and a carpeted box under the rear deck thats where the subs are.
crackerkorean is offline  
#7 (permalink) Old 09-26-2004, 02:08 PM
5th Gear Member
 
Join Date: Jul 2004
Posts: 1,028
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BeelZibub is an unknown quantity at this point
Will have a look tonite - maybe I'm missing out on something??? Thinking about it there is a higher spec system than mine - Apparently it adjusts the sound according to the speed of the car so the occupants still get an even sound from the stereo. Perhaps US spec cars all come with this system as standard - on UK models it was an EXPENSIVE option.
BeelZibub is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo Problem Solved! jeppcharts Audio and Electronics 0 09-04-2004 10:58 PM
Electrical Problem AC Stereo byttcool 5-Series (E12,E28, E34, E39, E60) 5 07-26-2004 10:13 AM
Car stereo connection problem? Wise_Owl 3-Series (E21, E30) 1 07-07-2004 02:12 AM
Car stereo connection problem :( Wise_Owl Audio and Electronics 1 07-06-2004 12:34 PM
87 325 stereo ground problem gfarns Audio and Electronics 1 06-11-2004 08:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome