Static "pop" & Burn? - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-08-2005, 12:21 AM
n00b
 
Join Date: Apr 2005
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
IDesigner is an unknown quantity at this point
(Thread Starter)
I have a '94 530I with a stock radio. In the past two or three days the radio has had a loud static. After the car has been on for 15-20 minutes the static seems to stop. Tonight while out on a quick errand static got louder then popped. Shortly after, I could smell something that smelled like burning insulation. Has anyone run into this or something close?

I want to keep keep the radio. It seems like the WB function would be hard to duplicate in aftermarket.
IDesigner is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Defrost causes static on Radio dedahed 5-Series (E12,E28, E34, E39, E60) 1 09-24-2005 12:57 PM
Problem With Burn Navigation Cd silt1 Audio and Electronics 2 07-18-2005 01:12 AM
Static When Rear Defrost Is On 1faste30 3-Series (E36) 5 11-06-2004 10:16 AM
Static Electricity Snowjob Wash & Detail 5 10-25-2004 10:36 PM
Speaker Static ROSinclair 1,6,7,8 - Series and Mini Cooper 1 04-28-2004 04:20 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome