Speedometer Not Working.. Help..!! - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-29-2004, 08:14 PM   #1 (permalink)
n00b
 
Join Date: Sep 2004
Car:
Posts: 3
Photos:
nalore1713 is an unknown quantity at this point
Unhappy

Helo People.. Help PLeaseeeeeee..

I'm new to this forum and I hope I can learn some/alot from this place.

My Brother has a 1999 BMW 528i 5 Speed manual.
About a month ago, his Speedometer stoped working.
The fuel gauge only works when the tank is full. After it hits about 1/4 to empty, the gauge starts to go up and down, and in the Message console that tells how many miles to empty does the same.. "the Numbers go up and down".

Any Idea of what is going on on this car. The only warning light are the ABS, and the Stability control.

Sometimes it works but only in the mornings. After it warms up, the warnings come ON and the Speedometer dropes and it never works again.

All fuse have been checked and can't find a faulty one...


Anyone out there has any sugestions. I would really apreciate any and all input,.

Thanks in advace.

-Alex
nalore1713 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-29-2004, 08:19 PM   #2 (permalink)
5th Gear Member
 
Hoppy's535i's Avatar
 
Join Date: Dec 2003
Location: Agawam/Bridgewater MA
Car:
Posts: 1,665
Photos:
Hoppy's535i is an unknown quantity at this point
check you instriment cluster fuses. mine would jiggle loose and i wouldnt have a tach. or spedo.
__________________
<span style='font-size:11pt;line-height:100%'><span style='color:blue'> theres no replacement for displacement </span></span>
im so hardcore. i dont even have cup holders
<img src='http://madmansrealm.com/forums/uploads/1101610420/gallery_18_1_1103159534.jpg' border='0' alt='user posted image' />
Hoppy's535i is offline   Reply With Quote
Old 09-29-2004, 08:23 PM   #3 (permalink)
n00b
 
Join Date: Sep 2004
Car:
Posts: 3
Photos:
nalore1713 is an unknown quantity at this point
Unhappy

Quote:
Originally posted by Hoppy's535i@Sep 29 2004, 09:19 PM
check you instriment cluster fuses. mine would jiggle loose and i wouldnt have a tach. or spedo.
[snapback]201723[/snapback]



Can you please elaborate a litle on that.. Sorry to sound dumb but I have no clue on bimmers. This is actually our first one.

Where is it located what you are asking me to check,.
nalore1713 is offline   Reply With Quote
Old 09-29-2004, 09:34 PM   #4 (permalink)
5th Gear Member
 
Hoppy's535i's Avatar
 
Join Date: Dec 2003
Location: Agawam/Bridgewater MA
Car:
Posts: 1,665
Photos:
Hoppy's535i is an unknown quantity at this point
what year and model car do you have? do you have the owners manual?
__________________
<span style='font-size:11pt;line-height:100%'><span style='color:blue'> theres no replacement for displacement </span></span>
im so hardcore. i dont even have cup holders
<img src='http://madmansrealm.com/forums/uploads/1101610420/gallery_18_1_1103159534.jpg' border='0' alt='user posted image' />
Hoppy's535i is offline   Reply With Quote
Old 09-29-2004, 11:30 PM   #5 (permalink)
n00b
 
Join Date: Sep 2004
Car:
Posts: 3
Photos:
nalore1713 is an unknown quantity at this point
Quote:
Originally posted by Hoppy's535i@Sep 29 2004, 10:34 PM
what year and model car do you have? do you have the owners manual?
[snapback]201770[/snapback]

I have the manula but it does not say anything abou tour situation. Again, the car is 1999 BMW 528i 5 SPEED MANUAL. IS A 4 DOOR SEDAN.


-ALEX
nalore1713 is offline   Reply With Quote
Old 09-30-2004, 09:29 AM   #6 (permalink)
5th Gear Member
 
Hoppy's535i's Avatar
 
Join Date: Dec 2003
Location: Agawam/Bridgewater MA
Car:
Posts: 1,665
Photos:
Hoppy's535i is an unknown quantity at this point
sorry, i musta skiped right over the year and model when i was reading

i dont own an e39, but im pretty sure the fuse pannel is in the trunk correct? im also not familiar with wich fuse does what, sorry i guesse i cant help you after all, anyone with a e39 service manual wanna help this guy out?
__________________
<span style='font-size:11pt;line-height:100%'><span style='color:blue'> theres no replacement for displacement </span></span>
im so hardcore. i dont even have cup holders
<img src='http://madmansrealm.com/forums/uploads/1101610420/gallery_18_1_1103159534.jpg' border='0' alt='user posted image' />
Hoppy's535i is offline   Reply With Quote
Old 10-02-2004, 10:49 AM   #7 (permalink)
5th Gear Member
 
billB's Avatar
 
Join Date: Aug 2004
Location: New Jersey
Car:
Posts: 1,635
Photos:
billB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond repute
Send a message via Yahoo to billB
Nalore1713

for Instrument cluster try fuses # 18 24 40 at least on my car. Also consider disconnecting you negative battery terminal for a while to reset the computer and to reinitializes. Old trick but works for me!!

good luck and best regards
billb
billB is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Z3 Speedometer Needle Not Working djs1122 1,6,7,8 - Series and Mini Cooper 1 07-11-2005 01:49 PM
Speedometer Needle Problem Todd Ferrie 3-Series (E21, E30) 3 07-02-2005 12:04 PM
Speedometer not working M5power 5-Series (E12,E28, E34, E39, E60) 9 03-29-2005 08:58 PM
Speedometer And Mpg Stopped Working Bimmer///Man3 3-Series (E36) 4 11-13-2004 08:40 AM
Speed sensor and speedometer, is there a link? :D M5power 5-Series (E12,E28, E34, E39, E60) 3 02-03-2004 08:18 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:14 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.