Speedometer not working - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2004, 02:00 AM   #1 (permalink)
Neutral Member
 
Join Date: Dec 2003
Car:
Posts: 94
Photos:
M5power is an unknown quantity at this point
the speedometer isn't working whatso ever on my gauge cluster, the RPM's and everything else work fine, the sensors on my diff looked fine to me, i took a look at em. but yeah i was wanting to see, i was told my best bet would be that my speedometer in my gauge is messed badly and that i need a new gauge cluster, is this the problem? or is there another thing that could be wrong and easily fixed? the speedometer on my obc isn't working at all either.
its actually my speedometer and my trip odometer are not working at all. thanks for any replies!
__________________
<img src='http://www.tehseen.net/david.jpg' border='0' alt='user posted image' />

The b0x that r0x
M5power is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-18-2004, 10:45 AM   #2 (permalink)
5th Gear Member
 
Hoppy's535i's Avatar
 
Join Date: Dec 2003
Location: Agawam/Bridgewater MA
Car:
Posts: 1,665
Photos:
Hoppy's535i is an unknown quantity at this point
check and see if its a fuse. my tach went out one time driving me to an absolute panic till i read the manual and checked the fuse, and sure enough that was it.
__________________
<span style='font-size:11pt;line-height:100%'><span style='color:blue'> theres no replacement for displacement </span></span>
im so hardcore. i dont even have cup holders
<img src='http://madmansrealm.com/forums/uploads/1101610420/gallery_18_1_1103159534.jpg' border='0' alt='user posted image' />
Hoppy's535i is offline   Reply With Quote
Old 01-18-2004, 01:38 PM   #3 (permalink)
2nd Gear Member
 
TECH's Avatar
 
Join Date: Jan 2004
Car:
Posts: 434
Photos:
TECH is an unknown quantity at this point
If the speedo AND the odo aren't working, it could be the signal to the instrument cluster.
What car do you have?
TECH is offline   Reply With Quote
Old 01-18-2004, 03:04 PM   #4 (permalink)
Neutral Member
 
Join Date: Dec 2003
Car:
Posts: 94
Photos:
M5power is an unknown quantity at this point
i have a 1985 528E
All of the fuses in that box under the hood are fine, are there any hidden ones i should check?
how could i check if it was the signal going to it? thanks!
__________________
<img src='http://www.tehseen.net/david.jpg' border='0' alt='user posted image' />

The b0x that r0x
M5power is offline   Reply With Quote
Old 01-18-2004, 05:05 PM   #5 (permalink)
2nd Gear Member
 
TECH's Avatar
 
Join Date: Jan 2004
Car:
Posts: 434
Photos:
TECH is an unknown quantity at this point
Wow, a dinosaur. I'll see about looking into it.
TECH is offline   Reply With Quote
Old 01-19-2004, 12:13 AM   #6 (permalink)
2nd Gear Member
 
EXtech's Avatar
 
Join Date: Jul 2003
Location: Texas
Car:
Posts: 497
Photos:
EXtech is an unknown quantity at this point
Don't fret yet. You need to pull the cluster out. Typically what happens is that corrosion builds up on the contacts between the gauges and the boards. Also, the attaching nuts coming loose which also creates a weak contact. Last but not least, you might also need to perform the board update with the nicad batteries. Check out pelicanparts.com, you can contact Jared there and he'll help you with your part purchase. Let 'em know I sent you.
__________________
STETT Performance -
Everything BMW
921 J Place, Suite 200
Plano, TX 75074
469-767-3309

OEM Repairs and Maintenance
Extended Warranty Service
Pre-Purchase Inspections
Everything Performance (brakes, turbos, Nitrous, Cams, Complete Engines, Clutches/Flywheels etc)
-----------

STETT Performance Official Grand Opening BMW Meet, May 6th 11A-3P -- Music, Food, Drawings and Tons of BMW's go to http://206.123.107.13/stett and register.. it's FREE
EXtech is offline   Reply With Quote
Old 01-19-2004, 10:56 AM   #7 (permalink)
Neutral Member
 
Join Date: Dec 2003
Car:
Posts: 94
Photos:
M5power is an unknown quantity at this point
i've taken out the cluster before, everything looked fine. but okies i'll go to that website, waht is your name so i know? and yeah its a dinosaur, but its still a good bmw
__________________
<img src='http://www.tehseen.net/david.jpg' border='0' alt='user posted image' />

The b0x that r0x
M5power is offline   Reply With Quote
Old 01-19-2004, 06:40 PM   #8 (permalink)
2nd Gear Member
 
EXtech's Avatar
 
Join Date: Jul 2003
Location: Texas
Car:
Posts: 497
Photos:
EXtech is an unknown quantity at this point
M5power, I spoke with Jared and he says to directly email him jared@pelicanparts.com
Just tell him EXtech sent you.

Old or not, you're right.. it's still a good car.
__________________
STETT Performance -
Everything BMW
921 J Place, Suite 200
Plano, TX 75074
469-767-3309

OEM Repairs and Maintenance
Extended Warranty Service
Pre-Purchase Inspections
Everything Performance (brakes, turbos, Nitrous, Cams, Complete Engines, Clutches/Flywheels etc)
-----------

STETT Performance Official Grand Opening BMW Meet, May 6th 11A-3P -- Music, Food, Drawings and Tons of BMW's go to http://206.123.107.13/stett and register.. it's FREE
EXtech is offline   Reply With Quote
Old 01-19-2004, 10:52 PM   #9 (permalink)
Neutral Member
 
Join Date: Dec 2003
Car:
Posts: 94
Photos:
M5power is an unknown quantity at this point
alrite, thanks alot for the help, this forum is great
__________________
<img src='http://www.tehseen.net/david.jpg' border='0' alt='user posted image' />

The b0x that r0x
M5power is offline   Reply With Quote
Old 03-29-2005, 08:58 PM   #10 (permalink)
n00b
 
MrAlfonze's Avatar
 
Join Date: Mar 2005
Location: Florida
Car:
Posts: 3
Photos:
MrAlfonze is an unknown quantity at this point
I have a 1983 528e one owner, it is immaculate, everything works except for speedometer and related items, i.e. cruise control, odometer/tripometer, the digital display works in all modes but speed and distance related. I am very DIY person, I have replaced trans axle sendering unit (cheapest fix) no success, replaced nicades on the cluster, the Varta's did not leak, board looks clean and no obvious burns or defects, both white and blue connectors on back of cluster are in correct posistion and places, however i did notice that the service indicator light cluster was removed along with it's ribbon cable that connects to cluster board. I was told to replace the cluster board, and would not mind spending the money if i knew for sure that it would fix situation.

Anyone have exactly the same problem and or maybe a test or check i can perform?

Any help would be appreciated
__________________
83 528e Factory Burgandy
01 Fatboy Vivid Black
03 Buell Blast Emegency Yellow (Wifes)
04 Road King Custom Silver Pearl Metalic
04 Sorento EX Sliver/Dark Grey
04 Optima EX V6 Gold Metalic (Wifes)
3 Kids
2 Dogs
1 Cat
(did I already mention the Wife?)

and a mortgage in someone's money tree
MrAlfonze is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Z3 Speedometer Needle Not Working djs1122 1,6,7,8 - Series and Mini Cooper 1 07-11-2005 01:49 PM
Speedometer Needle Problem Todd Ferrie 3-Series (E21, E30) 3 07-02-2005 12:04 PM
Speedometer And Mpg Stopped Working Bimmer///Man3 3-Series (E36) 4 11-13-2004 08:40 AM
Speedometer Not Working.. Help..!! nalore1713 5-Series (E12,E28, E34, E39, E60) 6 10-02-2004 10:49 AM
Speed sensor and speedometer, is there a link? :D M5power 5-Series (E12,E28, E34, E39, E60) 3 02-03-2004 08:18 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:58 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.