Speedo lost - ABS & ASC lights on - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-18-2007, 06:35 AM
arh
n00b
 
Join Date: Jan 2005
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
arh is an unknown quantity at this point
(Thread Starter)
Speedo lost - ABS & ASC lights on

Problem on my 1999 523i.

Both my ABS and ASC lights come on intermittently. It seems to happen when I have driven for 30 mins or more but it can be random. Speedo and MPG is also lost when these lights are on. It I switch the car off (when lights are on) and turn it back on the problem does not clear. Cruise control works all the time even when lights are on.

I've been reading that is either the abs sensor cable or the abs unit. What is the easiest way that I can diagnose? Is it easy to swap the to sensor cables over. How can I test the abs unit?

Thanks.
arh is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-18-2007, 08:43 AM
n00b
 
PhilH's Avatar
 
Join Date: Dec 2006
Location: England
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
PhilH is on a distinguished road
easiest way must be to have it connected to the computer.
PhilH is offline  
#3 (permalink) Old 07-20-2007, 05:15 PM
arh
n00b
 
Join Date: Jan 2005
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
arh is an unknown quantity at this point
(Thread Starter)
Update:
Went to BMW specialist who diagnosed problem with ABS unit. Computer diagnostics showed left rear sensor but changing this did not clear the fault.

Sent my unit to ecu-testing.com for repair and it came back today (cost 250 )

- put repaired unit back into car and now both ABS and ACS lights come on straightaway. The ABS unit also makes a load noise when checking the system when the car is started! I'm sure that it was not as loud before repair...

Please help... will contact repair company for advice tomorrow and give update.
arh is offline  
#4 (permalink) Old 07-21-2007, 02:43 PM
arh
n00b
 
Join Date: Jan 2005
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
arh is an unknown quantity at this point
(Thread Starter)
Panic is over as problem is resolved as both ABS and ASC lights are off and speedo is fine even after a long trip. I did read on another formum that once the ABS unit has been repaired it an take a little while to settle down. Mine seemed to be ok after the second time I drove the car.
arh is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E39 Traction Control and ABS warning lights DuncanThomas 5-Series (E12,E28, E34, E39, E60) 7 07-19-2011 02:50 PM
HELP - Brake, ABS, and DSC lights on Fangs 3-Series (E46, E90) 48 05-13-2011 02:39 PM
Problem: DCS and ABS lights on :( thejobman 5-Series (E12,E28, E34, E39, E60) 5 12-18-2008 05:25 AM
ABS and ACS lights on intermittently warchild M-Series (M1, M3, M5, M6) 2 01-03-2006 11:58 PM
Abs,asc Lights On + Speedo Not Working ghazanfer 5-Series (E12,E28, E34, E39, E60) 2 06-06-2005 12:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome