Seconary Air System - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-13-2005, 03:24 PM
n00b
 
Join Date: Mar 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
eric is an unknown quantity at this point
(Thread Starter)
first question whats a good fault code reader and where to get it cheap? i've been having problems with my secondary air system for about 7000 miles. I have about 54000 miles on my 1998 528i already replaced the air pump and control valve. I'm thinking of replacing the electronic valve also. Every time my friend resets the computer the check engine light dosen't go on for about 250 miles then it comes on again with the same codes for the secondary air system. today i took of the air hose that gose into the control valve and the pump didn't seem to be pumping. the valve seems to be ok. when i took the pump out it seemed to work ok. the hose is lets air through to the valve. i'm going out of my mine trying to figure this out. what other things could be wronge for the same codes to keep coming back????????????//
eric is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-13-2005, 05:08 PM
n00b
 
Join Date: Apr 2005
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
alpinewhite is an unknown quantity at this point
Post

Quote:
Originally posted by eric@Apr 13 2005, 03:24 PM
first question whats a good fault code reader and where to get it cheap? i've been having problems with my secondary air system for about 7000 miles. I have about 54000 miles on my 1998 528i already replaced the air pump and control valve. I'm thinking of replacing the electronic valve also. Every time my friend resets the computer the check engine light dosen't go on for about 250 miles then it comes on again with the same codes for the secondary air system. today i took of the air hose that gose into the control valve and the pump didn't seem to be pumping. the valve seems to be ok. when i took the pump out it seemed to work ok. the hose is lets air through to the valve. i'm going out of my mine trying to figure this out. what other things could be wronge for the same codes to keep coming back????????????//
[snapback]331633[/snapback]

The same thing happened to me. There is a relay and a fuse that may have to be changed everytime you put a new air pump. The relay is in the e-box, under the passenger site cabin filter (I don't know the number), the fuse is under the passenger side carpet, fuse #107. If the air pump is working and the air valve is good, then 90% change or higher that it is one or both of these items. DOn't spend money on it, dealer will sell you a new pump and charge over 600 bucks without solving the problem. If nothing works, buy a BMW reset tool and reset it just before the inspection, you have to drive above 50 miles to (to internally reset the computer) to pass the emission test.
al
alpinewhite is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Synthetic Oil and filter CiscoKid 3-Series (E36) 47 04-14-2014 07:00 PM
*The E36 Turbo Thread* SpeedInfusion 3-Series (E36) 9 10-16-2005 10:10 PM
The American Vs. The German billB 5-Series (E12,E28, E34, E39, E60) 83 10-14-2004 08:09 PM
New technology coming to 2005 Infiniti models AZ325Ci Other Rides 4 06-13-2004 10:14 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome