Reverse slow to engage? (Auto) - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-12-2009, 10:24 PM
n00b
 
Join Date: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95525 is on a distinguished road
(Thread Starter)
Reverse slow to engage? (Auto)

I recently purchased a 1992 525, 238k. When putting it into reverse there is about a 2 second delay then it engages smoothly other than that the trans feels good, the previous owner states it has been like that for a long time. I plan on doing a fluid/filter change soon.

Any similiar experiences, thoughts or quick fixes?

Thanks
95525 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-13-2009, 12:40 AM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
Could just be Low on fluid.... Fluid and filter chage then fill to the proper level could help it

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#3 (permalink) Old 06-13-2009, 10:15 PM
n00b
 
Join Date: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95525 is on a distinguished road
(Thread Starter)
The bently says dexron II apparently most auto places do not stock it. Where do you guys buy dexron II for your autotrans?
95525 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow take-off Lesang 3-Series (E46, E90) 3 04-01-2009 07:04 AM
e34 525td starter wont engage shawkins76@hotmail.com 5-Series (E12,E28, E34, E39, E60) 2 12-29-2008 03:59 PM
E39 - 2002 530i Won't Engage Park/Igntion Interlock The Deuce 5-Series (E12,E28, E34, E39, E60) 1 12-08-2008 10:22 AM
Slow engagement from reverse to drive tessbeemer 3-Series (E46, E90) 2 05-22-2008 10:19 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome