radio issues - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-17-2009, 10:58 PM   #1 (permalink)
n00b
 
Join Date: Jan 2009
Car:
Posts: 8
Photos:
thetallwun is on a distinguished road
radio issues

Hey guys, just registered on the site, so yea, i'm a newbie. I'm some what of a well read newbie, as I usually snoop around the site as a guest, admiring the ability of members to address common problems.

With that said, I have a problem. I've done a search to see if it has been talked about previously, but couldn't find anything, so my apologies if this has been previously discussed.

Today out of no where my nav radio decided to stop responding to my selections. The display button (the one that lights orange next to the left knob) no longer lights up. When I push the mode button to alternate btwn radio, cd changer, or tape, nothing happens. I can still here the radio, by the screen shot on my nav unit doesnt show the radio stations anymore. It simply stays at the main menu screen, so I have to guess which radio station i'm listening to. The radio is the only thing I can listen to. I use the tape deck to play my ipod, and that now has no sound, along with the cd changer.

I checked the cd changer in the trunk to make sure no cables came loose, that didn't work. I didn't know what else to check, so I unplugged and replugged the cables going to what I believed to be was the radio tuner to no avail.

If anyone can help me, i'd HIGHLY appreciate it, as I was planning to by the Intravee II soon, but since I can't select any other music source, it would be useless to me.

Specs: 1997 528i with factory 4:3 nav and a MkII comp.
thetallwun is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-17-2009, 11:11 PM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
I'm not overly familiar, but my guess is an internal issue with the unit.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 02-03-2009, 01:21 AM   #3 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
having similar problem with my nav radio but not exctly the same .... description is below:

When pushing the display button (the one that lights orange next to the left knob), the light is on only while I still pressed, but goes OFF if I release. The radio will only show certain channel number but with no voice. CD or tape nothing responds. Only I can use the menu button to go to the main menu screen.

Question, have you washed the car just before you experience the problem?

Any help ?
rashid is offline   Reply With Quote
Old 02-04-2009, 10:55 PM   #4 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
Any help on the above?
rashid is offline   Reply With Quote
Old 02-04-2009, 11:06 PM   #5 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Again, that seems like a unit internal issue.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 02-04-2009, 11:16 PM   #6 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
You mean replacing the whole unit??
rashid is offline   Reply With Quote
Old 02-04-2009, 11:34 PM   #7 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Possibly.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 02-04-2009, 11:42 PM   #8 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
Can not be repaired?
rashid is offline   Reply With Quote
Old 02-05-2009, 12:05 AM   #9 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Only the OEM of the unit knows that.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 02-11-2009, 09:46 AM   #10 (permalink)
n00b
 
Join Date: Oct 2008
Car:
Posts: 21
Photos:
94-540i is on a distinguished road
I have a 94 540i, and had problerms with original radio. There is a company out in LaJolla Claifornia that refurbs original BMW OEM radio's They did mine for about $ 170, works great. Transisitors leak with age. I don't have the company name with me, but will post later today. You could google it until then
94-540i is offline   Reply With Quote
Old 02-18-2009, 01:46 AM   #11 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
I have 530i, 2002 with full TV, Nav, CD, large screan system. My prolem is decribed below & remain unsolved ...

When pushing the display button (the one that lights orange next to the left knob), the light is on only while still pressed, but goes OFF if I release. The radio will only show certain channel number but with no voice. CD or tape ... nothing responds. Only I can use the menu button to go to the main menu screen ...

The problem is only with the radio, tape & CD but the nav, tv, voice recognistion, phones all works fine.

is there any unit in the system controlloing the radio, tape & cd only??
rashid is offline   Reply With Quote
Old 02-18-2009, 07:49 AM   #12 (permalink)
n00b
 
Join Date: Oct 2008
Car:
Posts: 21
Photos:
94-540i is on a distinguished road
Here is the name of the Company in CA that fixed my OEM Radio. You can call them and ask them what they think.

LaJolla Audio Repair
5151 Santa Fe St
San Diego, CA 92109
858-373-0596 ask for Cleeve Morrison. He knows what he is talking about.
94-540i is offline   Reply With Quote
Old 02-18-2009, 12:09 PM   #13 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
Thanks, just called him .. he advised me to check the control box which is located at the back, .. there are three boxes in the same place & I need to identify the right one.

Thanks for your help.
rashid is offline   Reply With Quote
Old 02-26-2009, 03:35 AM   #14 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
replaced the radio control box & it works fine.

thanks for your help.
rashid is offline   Reply With Quote
Old 02-26-2009, 04:37 AM   #15 (permalink)
2nd Gear Member
 
Join Date: Jan 2009
Location: UAE - Gulf Area
Car: 530i-2002 & E280-2007
Posts: 459
Photos:
rashid is on a distinguished road
Forgot to till you about the reason, ….. it is the water that damaged both the tail light & the radio controller, which is located behind the tail light (left one).

I don’t know really how that happened & how to avoid it in the future??!!
rashid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer Issues jshz2003 3-Series (E36) 2 04-29-2008 04:41 PM
A/c Issues PR bimmer 3-Series (E46, E90) 1 02-27-2008 02:29 AM
Need Radio Code For 1992 Business Radio danger450 3-Series (E36) 5 03-07-2005 11:35 AM
Help W/318ti Issues jersey 3-Series (E36) 1 01-16-2005 11:38 AM
More AC issues wulley1 3-Series (E36) 13 05-28-2004 06:31 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.