problems with my 91 525i - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-16-2010, 01:22 AM   #1 (permalink)
n00b
 
Join Date: Mar 2010
Car:
Posts: 1
Photos:
parkersbudd is on a distinguished road
Angry problems with my 91 525i

one day it back fired and ever since then it wont run it will start as long as i am on the gas but it wont idle on its own. i was told that the problem was that the timing jumped but i want to know if that's possible and if that's what happened how do i fix it? plz help
parkersbudd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-16-2010, 06:48 AM   #2 (permalink)
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Car: 88 super ETA, 95 525i
Posts: 1,494
Photos:
darkhorse737 is on a distinguished road
look at your intake hoses and make sure none of them were blown off their places as a result of the backfire.

then take a good look at your MAF(Mass Airflow Sensor) clean if dirty. OR,

try pulling out the plug of the MAF. Start car. If ur car runs better without the MAF connected, changed are it went bad.

Good Luck
darkhorse737 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 BMW 525i m20 2 problems? Duanevw 5-Series (E12,E28, E34, E39, E60) 0 03-15-2006 04:03 PM
1995 525i: Several Problems Any Tips? huffj786 5-Series (E12,E28, E34, E39, E60) 8 10-22-2004 10:22 AM
E34 525i Ignition problems blackmanworking 5-Series (E12,E28, E34, E39, E60) 1 07-24-2004 03:32 PM
Problems with memory seat, 525I jam05 5-Series (E12,E28, E34, E39, E60) 1 09-25-2003 11:38 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:06 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.