Power loss and smoke on my 2003 525d - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-03-2009, 04:51 AM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MemphysX is on a distinguished road
(Thread Starter)
Power loss and smoke on my 2003 525d

Hi guys. Could someone help me determine my problem. I have quite a power loss on my 2003 525d and some black smoke when i accelarate? My guess that it is the MAF sensor. My car is a BMW 2003 525dA M-paket Individual with about 140k miles and i've done 0-60mph in 9.6 and 10.1 when it should in 9.1.

Last edited by MemphysX; 04-03-2009 at 04:59 AM.
MemphysX is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-04-2009, 04:16 PM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MemphysX is on a distinguished road
(Thread Starter)
Somebody pls help!!!
MemphysX is offline  
#3 (permalink) Old 04-04-2009, 08:16 PM
5th Gear Member
 
CosmosBlack's Avatar
 
Join Date: Jul 2003
Location: Florida
Posts: 1,287
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute
It could be due to so many things, to troubleshoot, you really need more signs and symptoms.
Does the car jerk on acceleration, does it idle rough, does it do it all the time or only warm/cold, any CEL....etc etc.
I would think if it's the MAF sensor, you would have a CEL.

CosmosBlack is offline  
#4 (permalink) Old 04-04-2009, 08:44 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
It can't hurt to check the fuel system. Maybe a bad injector or two.

BMW

Sig by zeaq
witeshark is offline  
#5 (permalink) Old 04-05-2009, 09:20 AM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MemphysX is on a distinguished road
(Thread Starter)
I could say that it works too fine, you can't almost hear the diesel sound, it works almost like a petrol engine. The only thing is that you can't feel the power, and it doesn't matter if it is cold or warm. The car smokes only in hard accelarations, the exhaust smells ok. The only thing i don't like is that the automatic gearbox changes to fast in higher gears. I checked the car on a computer and everything is alright (injectors, supercharger), the only thing the computer said is that the car lacks 10% of air, and the guess is that it is the MAF sensor. What is CEL?
MemphysX is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 525d E39 Salon Keys Locked in Boot !!! KKBMW525d 5-Series (E12,E28, E34, E39, E60) 2 11-08-2008 08:57 AM
Loss of power eduardope 3-Series (E36) 20 09-26-2007 07:18 PM
E46 loss of power, DDE light on constant, and smoke from exhaust? angela 3-Series (E46, E90) 2 03-03-2007 02:53 AM
Loss of power flipsgonetopless 3-Series (E21, E30) 10 08-05-2004 02:41 PM
Power Loss BlackEye 5-Series (E12,E28, E34, E39, E60) 6 08-21-2003 03:28 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome