Please help with this problem. - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-14-2012, 07:25 AM
n00b
 
Join Date: Mar 2010
Location: georgia
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rgonz is on a distinguished road
(Thread Starter)
Please help with this problem.

I have a 2000 540i and lately I been experiencing a problem with a sqeeling noise followed by oil level/pressure light flickering. After driving around 20 miles I get the sound then the light then I shut off the engine and get a check oil level on screen. The only thing I see is coolant spitting out of the expansion reservoir. What I'm thinking is the coolant is dripping on the belt making the noise and causing the belt to the alternator to slip causing a drop in voltage giving me the light. Is this feasable??
rgonz is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-15-2012, 02:29 AM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
Have you checked your oil level? Are their any visible oil leaks?

Spitting out how? How much coolant is left in the system?


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#3 (permalink) Old 09-17-2012, 08:20 AM
n00b
 
Join Date: Mar 2010
Location: georgia
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rgonz is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by Lord Vader View Post
Have you checked your oil level? Are their any visible oil leaks?

Spitting out how? How much coolant is left in the system?
The oil level is full. I think I know what the problem is after looking at it a little bit longer. The reservoir is crack and splashing coolant on the belts. I ordered new belts, new reservoir and new radiator cap. This should take care of the problem I hope' but thanks for the reply.
rgonz is offline  
#4 (permalink) Old 09-17-2012, 06:42 PM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
Sounds good. Let us know how it works out for you. Its common for the Expansion Tank to crack.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#5 (permalink) Old 09-19-2012, 02:59 AM
n00b
 
Join Date: Aug 2012
Location: new york
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Juliann is on a distinguished road
i would advice you that its better for you to show your car problem to nearest bmw service station as they would better solve your problem rather than us
Juliann is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with my E36 325. Head problem? ppespepe 3-Series (E36) 1 08-08-2010 12:51 PM
Heater Problem And Oil Problem floydzeppelinfan 3-Series (E36) 1 04-07-2005 11:19 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome