Please help! E39 wont stay on misfires - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-22-2010, 09:55 PM   #1 (permalink)
n00b
 
Join Date: Mar 2010
Car:
Posts: 5
Photos:
J8291197 is on a distinguished road
Please help! E39 wont stay on misfires

I have a BMW 528i 1998. I am in need of some info desperately!
Here is whats going on... My car would stutter everytime I gave it a decent amount of gas on the pedal then it would smooth out. Shortly after this started happening the Check Engine light came on. Took the car to a place to read the codes and they told me I had a misfire on cyl 5 and something to do with fuel. They suggested replace the fuel filter and use a can of sea foam because the cylinders may not be getting enough fuel. I replaced the fuel filter and dumped in the can of sea foam and filled the tank up with gas. At this point i was excited thinking wow this should be what it needed. Took the car for a test drive and CEL was still on so I had the place reset the codes. On the way home it started shaking and stuttering and on came the CEL. After keeping the car off for a while i thought id give it another try the car cranked right up with no CEL but as soon as i start to give it gas while in park it stalls out and now i cant even drive it.

The car has ran out of gas once and I tend to wait until gas is very low to fill up.
I changed the spark plugs the same day it started to stutter and shake same results after i changed them. There was oil on the top of two of the old spark plugs that i changed out.
the car has 167k miles.
Someone help me get on track with the car.
J8291197 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-22-2010, 11:29 PM   #2 (permalink)
Mr. Clean
 
BimmerE39's Avatar
 
Join Date: Jan 2009
Location: Danbury, Connecticut
Car: Titanium Silver E39 / 2011 BMW M3
Posts: 1,817
Photos:
BimmerE39 will become famous soon enough
Garage
Quote:
Originally Posted by J8291197 View Post
I have a BMW 528i 1998. I am in need of some info desperately!
Here is whats going on... My car would stutter everytime I gave it a decent amount of gas on the pedal then it would smooth out. Shortly after this started happening the Check Engine light came on. Took the car to a place to read the codes and they told me I had a misfire on cyl 5 and something to do with fuel. They suggested replace the fuel filter and use a can of sea foam because the cylinders may not be getting enough fuel. I replaced the fuel filter and dumped in the can of sea foam and filled the tank up with gas. At this point i was excited thinking wow this should be what it needed. Took the car for a test drive and CEL was still on so I had the place reset the codes. On the way home it started shaking and stuttering and on came the CEL. After keeping the car off for a while i thought id give it another try the car cranked right up with no CEL but as soon as i start to give it gas while in park it stalls out and now i cant even drive it.

The car has ran out of gas once and I tend to wait until gas is very low to fill up.
I changed the spark plugs the same day it started to stutter and shake same results after i changed them. There was oil on the top of two of the old spark plugs that i changed out.
the car has 167k miles.
Someone help me get on track with the car.
Your first problem is your run the tank down until it's low until you fill it up. It's not good for the fuel lines, the fuel filter, fuel injection system, or engine because of the amount of sediment you probably have sitting in your fuel tank. I highly recommend not doing that from here on out.

You said that you replaced your spark plugs but did you change your boot connectors or the coil itself. When they wear out you can suffer from a weak spark or no spark at all. This can cause misfiring in cylinder 5 very easily.
__________________
BimmerE39 is offline   Reply With Quote
Old 03-22-2010, 11:49 PM   #3 (permalink)
n00b
 
Join Date: Mar 2010
Car:
Posts: 5
Photos:
J8291197 is on a distinguished road
thanks

After looking all over under the hood I noticed a loose hose under the rubber intake housing I pushed it back in and now it's running and driving. Still stuttering if I step on the gas hard but no CEL yet.
J8291197 is offline   Reply With Quote
Old 03-24-2010, 08:40 PM   #4 (permalink)
n00b
 
Join Date: Mar 2010
Car:
Posts: 5
Photos:
J8291197 is on a distinguished road
Quote:
Originally Posted by BimmerE39 View Post
Your first problem is your run the tank down until it's low until you fill it up. It's not good for the fuel lines, the fuel filter, fuel injection system, or engine because of the amount of sediment you probably have sitting in your fuel tank. I highly recommend not doing that from here on out.

You said that you replaced your spark plugs but did you change your boot connectors or the coil itself. When they wear out you can suffer from a weak spark or no spark at all. This can cause misfiring in cylinder 5 very easily.
Hey just wanted to say thanks for the info. Ran some code saying misfire on cyl 5 so i switched the coil from cyl 5 to 3 cleared the codes then drove the car until CEL came back on and this time it was misfiring on cyl3. turned on the car and one by one disconnected then reconnected each coil to make sure that was the only bad one. Went to auto zone and bought a new one and now she is running almost like new.

While doing all this it ran a code for bank 1 and 2. Just like you said letting my tank go so low on gas was going to cause problems. Thanks again I am going to look into cleaning my injectors this weekend.
J8291197 is offline   Reply With Quote
Old 03-27-2010, 03:51 PM   #5 (permalink)
Neutral Member
 
wayne adesso's Avatar
 
Join Date: Dec 2009
Location: vacaville ca
Car: 1998 528i alpine/wt/low/celis
Posts: 51
Photos:
wayne adesso is on a distinguished road
Nice job BimmerE39! Good to see a success story. Keep up the good work.
__________________
528imwayne
wayne adesso is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
trip odometer, clock, wont stay set mweibel0108 3-Series (E46, E90) 10 08-05-2013 12:00 AM
New Guy From NC... w/ Misfires and no idle averageguy New Members Check In 10 06-05-2009 10:40 PM
Misfires and multiple codes Icecold 3-Series (E46, E90) 1 03-01-2009 05:53 AM
Help Random Misfires 1999 323i E46 bkpiper00 3-Series (E46, E90) 7 11-16-2008 01:31 AM
my car kinda misfires preyash 3-Series (E36) 3 05-29-2006 11:17 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:14 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.