no power - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-23-2010, 11:52 PM   #1 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 13
Photos:
mrpuffin708 is on a distinguished road
no power

I have a 90 525 that has some problems. It hesitates really bad and seems to have no power or torque. Also my check engine light comes on when coasting downhill. As soon as a touch the gas it turns off. I dont get any codes besides the no faults found using the stomp test. Thanks in advance
mrpuffin708 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2010, 02:34 AM   #2 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Try disconnecting your Air Flow Sensor and see if there is any difference in the performance. I had similar issues (particularly when cold) without the coastig warning light. By disconnecting my AFS (AMS) the Engine Management goes into a default bypass mode and improves the performance. If you do get a positive result by doing this, try removing the sensor and cleaning it with brake cleaner or the specialist Air Flow Sensor cleaning product. Your might be lucky and fix the problem, otherwise you are probably looking at buying a replacement unit.
Good Luck
__________________

Riding in style
brettski is offline   Reply With Quote
Old 09-24-2010, 07:38 AM   #3 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 13
Photos:
mrpuffin708 is on a distinguished road
I have cleaned the air flow sensor recently as well ar rewired the sensor. Before that i was gettin a code from it but not now. And i forgot to add that i can smell fuel from the exhaust
mrpuffin708 is offline   Reply With Quote
Old 09-24-2010, 08:27 AM   #4 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
I'd still try disconnecting it and see if anything changes. If its feeding bogus information to the ECU the air fuel mix will be out.
__________________

Riding in style
brettski is offline   Reply With Quote
Old 09-24-2010, 03:45 PM   #5 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 13
Photos:
mrpuffin708 is on a distinguished road
I will try that as soon as i get back to my car. Is it gonna make an instant differance or do i need to drive it a little to see?
mrpuffin708 is offline   Reply With Quote
Old 09-24-2010, 10:17 PM   #6 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 13
Photos:
mrpuffin708 is on a distinguished road
Ok. I disconnected the air flow sensor and the car just died. I assume that is bad. Any thing else i could try before i spend money?
mrpuffin708 is offline   Reply With Quote
Old 09-25-2010, 09:24 AM   #7 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Did you do it with the car running, or before you started it?
__________________

Riding in style
brettski is offline   Reply With Quote
Old 09-26-2010, 06:25 PM   #8 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 13
Photos:
mrpuffin708 is on a distinguished road
I did it with the car running. I started it that way and it took a lot of cranking. I assume that isnt good
mrpuffin708 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
More Power Jonesz0003 M-Series (M1, M3, M5, M6) 6 08-13-2009 02:52 PM
more power !!!!!!!!!! ranky 3-Series (E46, E90) 2 05-19-2009 11:33 PM
1996 328i Power Window and Power Locks Problem stv 3-Series (E36) 14 07-27-2008 09:44 AM
More POWER!!! mob_intl 3-Series (E46, E90) 6 11-19-2005 01:00 AM
How Can I Get More Power jrmexican 3-Series (E21, E30) 14 02-05-2005 04:18 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:07 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.