No fuel and no Spark 98 540i Crank sensor? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-02-2012, 08:08 PM   #1 (permalink)
n00b
 
Join Date: Jul 2012
Car:
Posts: 1
Photos:
neonphire8604 is on a distinguished road
No fuel and no Spark 98 540i Crank sensor?

I just finished a motor swap on my 98 540i. I installed a JB race flywheel and I think it broke the crank position sensor. The thing is I cant tell if tone wheel is what broke it or if I broke it unintentionally while trying to remove it to examine it. I am a Honda Technician, not a do it yourself-er and am pretty sure I didn't break it but I know how brittle old plastic can be. Has anyone tried to replace the crank sensor and broke it in the process? Either way its broken so I bought a new one.

Would a broken Crank sensor cause the PCM to not energize the fuel pump relay on one of these cars? If it was a Honda I would say no. Its my first BMW so I simply do not know. The alarm was going off sporadically when trying to crank it, I attributed this to my weak battery but is that wrong? does the alarm module communicate with the immobilizer? no fuel and no spark makes me think of all sorts of horrible immobilizer issues and factory scan tools. This car did sit dead for about 3 years so could I have a module coding issue?

I bought the car with the engine pretty much removed from it so I had to figure out for myself where all the plugs went but that was easy so I doubt I have an issue their.

Yes the fuel pump and fuel pump relay work because I know someone is going to ask me that. Does anyone have any suggestions for me?
neonphire8604 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
crank sensor dudehog 3-Series (E36) 7 11-16-2009 05:33 AM
crank sensor olynicole 3-Series (E36) 4 03-08-2009 07:04 PM
Possible Crank Position Sensor problem. Help please... sc_trini 3-Series (E36) 1 09-28-2008 04:29 PM
where is crank pulse sensor?? thegavo 3-Series (E36) 5 08-30-2004 09:55 PM
where is crank pulse sensor?? thegavo 3-Series (E21, E30) 0 08-29-2004 04:45 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:08 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.