new 520i with minor idle issues - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-05-2006, 08:57 AM   #1 (permalink)
n00b
 
Morgenster's Avatar
 
Join Date: Sep 2005
Location: Antwerp, Belgium
Car:
Posts: 29
Photos:
Morgenster is on a distinguished road
new 520i with minor idle issues

used: Hi,

I posted earlier about my search for an e34 520i with m50 engine.
I found and bought one that has 260000 km on it.
The previous owner replaced the radiator, hoses, silentblocs in the rear and the MAF.
It drives real nice.
It has an LPG aspiration system which will save me tons of money at the pump. (I do about 1500 miles a month).
Something's bugging me a little though:
At starting (relatively cold or cold starts). Idle is fine at first, but after revving the first time idle can sometimes drop real low, like 400 rpm or even stall. That goes away after a few miles of driving, but even then idle is stable, but never really smooth and it looks as if the idle control valve can't decide on how far to open. So idle stable, but idle speed can vary abrubtly (never over 1K rpm).
I'm wondering now if this could be due to the throttle position sensor.

The bentley manual says the TPS is non-serviceable, but has anyone ever tried cleaning it?

I'm going to measure the resistance and voltage tomorrow at work.
Does anyone here know what else could be causing this?
Morgenster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-05-2006, 11:07 AM   #2 (permalink)
n00b
 
Join Date: Apr 2006
Car:
Posts: 10
Photos:
tracetrimble is on a distinguished road
Clean the IAC if possible.
__________________
2002 540i sport auto
tracetrimble is offline   Reply With Quote
Old 05-05-2006, 12:54 PM   #3 (permalink)
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Car: e36 w/ a m42
Posts: 14,878
Photos:
Torque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond repute
Do yourself a favor and download the Bentley Manual pinned at the top of the 5 series forum. Most things that apply to the m50 525i are same for your car.
__________________
Torque is offline   Reply With Quote
Old 05-05-2006, 10:07 PM   #4 (permalink)
Sodium Chloride
 
saltshaker185's Avatar
 
Join Date: Feb 2006
Location: Louisville Ky
Car: 95 M3
Posts: 3,762
Photos:
saltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to beholdsaltshaker185 is a splendid one to behold
Send a message via AIM to saltshaker185 Send a message via MSN to saltshaker185
clean out the ICV with an alcohol based cleaner and see if it does it anymore...
saltshaker185 is offline   Reply With Quote
Old 05-06-2006, 03:34 AM   #5 (permalink)
n00b
 
Morgenster's Avatar
 
Join Date: Sep 2005
Location: Antwerp, Belgium
Car:
Posts: 29
Photos:
Morgenster is on a distinguished road
Quote:
Originally Posted by tracetrimble
Clean the IAC if possible.
Did you mean ICV?

It's the weirdest thing: the Bentley manual says you should be able to reach the ICV without removing the intake manifold, but I can't even see it in there.
Is it close to the throttle butterfly or elsewhere?

I'm probably going to replace a number of vacuum hoses anyway since they've likely had a rough time with LPG backfires from time to time. And add a backfire release valve to the intake system.

The Bentley manual is very helpful, but sometimes still a little lacking in illustration...
Morgenster is offline   Reply With Quote
Old 05-06-2006, 07:16 AM   #6 (permalink)
n00b
 
Morgenster's Avatar
 
Join Date: Sep 2005
Location: Antwerp, Belgium
Car:
Posts: 29
Photos:
Morgenster is on a distinguished road
Just tested resistance between terminal 1 and 2 of the Throttle position sensor. With throttle fully closed I get 2K ohms instead of 1K.
Terminal 1 to ground doesn't read anything.
With throttle opening from closed to ful resistance does vary linearly from 2K to 5.6K ohms.

So to get back to my original question:

is this TPS faulty? and if not: why am I not getting voltage between terminal 1 and the engine ground wire with igntion on?

Do you guys think that swapping out the TPS for a new one will solve the problem even moderately?

Oh, and what's the partnumber?

Thanks a bunch!!!

OH, almost forgot: there's no surging idle thing going on. It just idles too low when cold (after the first tap on the accelarator) and idle speed changes in phases like as if the ECM is trying to adjust idle speed but doesn't get the right info. In between changes idle is constant.

Last edited by Morgenster; 05-06-2006 at 07:29 AM.
Morgenster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel issues? Car bogging! ReaverJam 3-Series (E21, E30) 5 10-04-2005 10:16 PM
Storage Issues offabroadway 3-Series (E21, E30) 6 08-09-2005 12:54 AM
Some Issues In My '91 520i Euro Spec backindauk 5-Series (E12,E28, E34, E39, E60) 16 05-15-2005 02:46 AM
Electrical Issues fireblade97rr 5-Series (E12,E28, E34, E39, E60) 5 10-17-2004 03:48 PM
2000 740i Issues vevro 1,6,7,8 - Series and Mini Cooper 1 04-21-2004 01:07 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:17 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.