Need Somehelp On My Heater Please - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-20-2004, 07:13 AM
n00b
 
Join Date: Sep 2004
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
andymarshal is an unknown quantity at this point
(Thread Starter)
i tried searching the forum but didnt really find anything, i have a 99 540ia 63000 miles, just this morning my heater stopped working no matter what settings i have on the climate - i only get cold air no matter where i direct it, the fan and all the other buttons work but i only get cold air even when the engine is fully warmed up i get no difference, please help.

thanks

andy
andymarshal is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-20-2004, 09:11 AM
5th Gear Member
 
billB's Avatar
 
Join Date: Aug 2004
Location: New Jersey
Posts: 1,635
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute
Send a message via Yahoo to billB
Quote:
Originally posted by andymarshal@Nov 20 2004, 01:13 PM
i tried searching the forum but didnt really find anything, i have a 99 540ia 63000 miles, just this morning my heater stopped working no matter what settings i have on the climate - i only get cold air no matter where i direct it, the fan and all the other buttons work but i only get cold air even when the engine is fully warmed up i get no difference, please help.

thanks

andy
[snapback]234239[/snapback]
Did you check your heater control valve in the fire wall area?
billB is offline  
#3 (permalink) Old 11-20-2004, 09:26 AM
n00b
 
Join Date: Sep 2004
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
andymarshal is an unknown quantity at this point
(Thread Starter)
Quote:
Originally posted by billB+Nov 20 2004, 02:11 PM--><div class='quotetop'>QUOTE(billB @ Nov 20 2004, 02:11 PM)</div><div class='quotemain'><!--QuoteBegin-andymarshal@Nov 20 2004, 01:13 PM
i tried searching the forum but didnt really find anything, i have a 99 540ia 63000 miles, just this morning my heater stopped working no matter what settings i have on the climate - i only get cold air no matter where i direct it, the fan and all the other buttons work but i only get cold air even when the engine is fully warmed up i get no difference, please help.

thanks

andy
[snapback]234239[/snapback]
Did you check your heater control valve in the fire wall area?
[snapback]234248[/snapback]
[/b][/quote]

thanks for the reply bill but i dont know what you mean when you say firewall and where would i find the heater control valve, sorry bill but as you probably guessed im not very technical

thanks
andy
andymarshal is offline  
#4 (permalink) Old 11-20-2004, 10:18 AM
5th Gear Member
 
billB's Avatar
 
Join Date: Aug 2004
Location: New Jersey
Posts: 1,635
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute
Send a message via Yahoo to billB
You may be facing one of the following:
1. As I mentioned earlier it can be as simple as a Heater valve manifested in a bad diaphragm.
2. It can be a temp sensor at either side.
3. It can be as bad as a problem with the Auto climate control unit itself either physical under the dash or logical in its programming.

As you can see the troubleshooting process can escalate from the least to the most complicated (thus more expensive) solutions.

P.S. Andy is it possible to get some help from a friend/relative/local mechanic who knows more about auto mechanics? As such you can pinpoint the exact problem through proper diagnostics. Iíll not feel so comfortable working on a complicated system like the 540 all by myself if I am not equipped with the proper knowledge; otherwise it may cost you more in terms of safety and money.
I am sorry if this is not much of a help and I wish you Good luck
Regards
billb
billB is offline  
#5 (permalink) Old 11-21-2004, 06:54 PM
n00b
 
Join Date: Sep 2004
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
andymarshal is an unknown quantity at this point
(Thread Starter)
ok bill i found the problem, the dreaded crack in the rad left me with a dangerously low coolant level, however my obc never gave me a warning?

below is an email i sent to bmw customer service, i will keep you updated, get behind me on this boys

Hello, I have been the proud owner of a bmw 540 for the past few months and have been very pleased ith performance and build quality. However i have recently noticed a crack around the top section of the radiator which is slowly leaking coolant.

My car has 64000 miles on the clock and a full bmw service hiatory, surely a car of this calibre should not get trough a radiator at this age. Having performed a search on the internet for this problem it seems to be a common occurance on most e39's and is even considered on some web pages as a "common fault".

Having considered bmw as a high quality car manufacturer, i find it hard to beleive that this seems to be a common occurance especially on a low mileage car with a full bmw service history.

I would like to know what bmw's position on this problem.

kind regards

Andrew Marshal

andymarshal@aol.com
andymarshal is offline  
#6 (permalink) Old 11-21-2004, 11:13 PM
5th Gear Member
 
billB's Avatar
 
Join Date: Aug 2004
Location: New Jersey
Posts: 1,635
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute billB has a reputation beyond repute
Send a message via Yahoo to billB
Very Interesting....loosing all that coolant on a 540 without noticing a rising temp gauge (at least passing the half mark) and/or hearing an overworked aux. electrical cooling fan!!!

When you say the top section of the rad; I am assuming you mean the neck where the upper big hose is attached. It is made of plastic and you must be extremely careful when applying torque to tighten the hose over it. In fact over torque will crack it. I've seen it cracking once when a "smart mechanic" leaned on it with his left hand (while changing a fan belt).

Note: BMW can respond to your email/inquiry saying this crack is due to misuses not defects in their material. Also they may demand a physical inspection for final determination. Either way good luck and let us know of the final outcome.

regards
billb
billB is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater Problems DKMassive 5-Series (E12,E28, E34, E39, E60) 0 07-06-2005 11:07 PM
Heater Problem Bmmf40 5-Series (E12,E28, E34, E39, E60) 1 07-04-2005 12:38 AM
Heater Core ? walshja 3-Series (E36) 8 01-19-2005 06:39 PM
Interesting Heater Behavior hockey_fan 3-Series (E36) 6 11-04-2004 12:24 AM
Analog to Digital Heater Conversion Digital318is 3-Series (E36) 3 04-02-2004 02:34 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome