Need Help with Error code: P1554 & P1551 - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-05-2010, 12:12 PM
n00b
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rez999 is on a distinguished road
(Thread Starter)
Need Help with Error code: P1554 & P1551

Hi all,
on my 2007 525XI with 70K miles (out of warranty by 10K sucks!)
the other day I got an engine warning signal came out.
I used my OBD II to get a reading, below are the codes with discriptions:

P1554 = Idle Speed Control Throttle Position Basic Setting Conditions not met
P1551 = Barometric Pressure Sensor Circuit Short to B+

I cleard the errors with the OBD, then today after 2 days of driving the signal warnign apeard again on my console.
I called BMW dealer, they need to check it out and off cource under usual big$ expense.

Can Anyone assist with these errors exactly what they mean and with a bit of technical background if I can fix it myself. Has anyone had the same issue and how was it fixed?
cheers

2007 525XI
Black on Black
Rez999 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-12-2010, 10:18 PM
n00b
 
Join Date: Dec 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
reffio is on a distinguished road
hi, i have the same problem, i replaced the 2 camshaft sensors, maf sensor,throttle body, and i still having the same problem, but also when i drive the car, i feel like the car doesnt have too much power, please let me know if you could fix your car, thanks.
reffio is offline  
#3 (permalink) Old 03-28-2010, 10:42 AM
n00b
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cparke is on a distinguished road
Another car with the P1554 problem

I just bought a used 2007 BMW 328xi, and this fault code has just appeared for me too!

Another description of this code (taken from the 2006 330i DTC list) is:
P1554 - Engine Position System 'A' Performance (Bank 1)

My car just rolled over 50,000 miles too, so out of luck with BMW's manufactuer warranty for covering it. I do, however, have the statutory state used car dealer lemon law warranty and an extended warranty (subject to deductible). I'm bringing the car back to the used dealer for them to look at the problem, but of course I'm not getting my hopes up that they'll do much more than clear the code and say it has been fixed (it is quite inconvenient to bring the car back too).

I do note that when I put my key into the slot and switch the car's ignition system ON (but not start the engine), there is a high pitched noise coming from under the hood which lasts for maybe 5 minutes (is that normal?). While I don't have a repair manual for the car, I suspect the fault code is related to this noise, and in particular that throttle body adaptation is failing. My freeze frame confirms the code was thrown just after starting the engine.

The fact that the throttle body was actually changed by someone here and that didn't fix the problem suggests to me that maybe the P1554 is related to some other related sensor failing, such as the throttle position sensor?

Really, has no one yet gotten this problem fixed? I really need to make sure the right part is fixed, not a bunch of other parts that really are good. Thanks.
cparke is offline  
#4 (permalink) Old 03-29-2010, 01:54 PM
n00b
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rez999 is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by cparke View Post
I just bought a used 2007 BMW 328xi, and this fault code has just appeared for me too!

Another description of this code (taken from the 2006 330i DTC list) is:
P1554 - Engine Position System 'A' Performance (Bank 1)

My car just rolled over 50,000 miles too, so out of luck with BMW's manufactuer warranty for covering it. I do, however, have the statutory state used car dealer lemon law warranty and an extended warranty (subject to deductible). I'm bringing the car back to the used dealer for them to look at the problem, but of course I'm not getting my hopes up that they'll do much more than clear the code and say it has been fixed (it is quite inconvenient to bring the car back too).

I do note that when I put my key into the slot and switch the car's ignition system ON (but not start the engine), there is a high pitched noise coming from under the hood which lasts for maybe 5 minutes (is that normal?). While I don't have a repair manual for the car, I suspect the fault code is related to this noise, and in particular that throttle body adaptation is failing. My freeze frame confirms the code was thrown just after starting the engine.

The fact that the throttle body was actually changed by someone here and that didn't fix the problem suggests to me that maybe the P1554 is related to some other related sensor failing, such as the throttle position sensor?

Really, has no one yet gotten this problem fixed? I really need to make sure the right part is fixed, not a bunch of other parts that really are good. Thanks.
--------
I checked with my dealer who mentioned it might be the "Barometric Pressure Sensor" but intresting enough the engin light disapread by itself two weeks ago and has not give me the warning since!!
I will ask my dealer to change the sensor once I take it for next oil change. this might help to reduce my Gas consumption that I am getting 13.1L/100KM avrage HW/city drive.

2007 525XI
Black on Black
Rez999 is offline  
#5 (permalink) Old 03-29-2010, 02:05 PM
n00b
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cparke is on a distinguished road
Quote:
Originally Posted by Rez999 View Post
--------
I checked with my dealer who mentioned it might be the "Barometric Pressure Sensor" but intresting enough the engin light disapread by itself two weeks ago and has not give me the warning since!!
I will ask my dealer to change the sensor once I take it for next oil change. this might help to reduce my Gas consumption that I am getting 13.1L/100KM avrage HW/city drive.
My Check Engine light went out today on its own. The code is still stored however. I had a repair shop scan for BMW-specific codes, and indeed like the other poster in this thread, there are BMW codes stored for crankshaft sensors, etc. The problem is obviously an intermittent electrical issue in these vehicles.

The repair shop, the extended warraty, and the used dealer (liable under the state mandatory used car dealer's warranty) are now deciding how they handle these repairs. Sounds like no one here has yet determined the real problem that needs to be fixed, however. BTW - I do not have the P1551 Barometic Pressure Sensor code presently.
cparke is offline  
#6 (permalink) Old 04-09-2010, 04:34 PM
n00b
 
Join Date: Feb 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
desantim is on a distinguished road
Just as an addition, I just purchased my 06 325i with 52k on the clock on Tuesday, light came on today with the P1554 error, turned the car off, left it overnight, and the light ended up going out on its own as well.

Kinda weird. At least it isn't a big deal. I was like **** me!

lol
Mario
desantim is offline  
#7 (permalink) Old 04-29-2010, 10:06 PM
n00b
 
Join Date: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cristancho is on a distinguished road
I had the same issue with my 2000 323I. Called Bavarian autosport BMW Parts and BMW Accessories | Bavarian Autosport and they sold me two camshaft sensors the intake side and the exhaust side. They seemed to have fixed the problem.
cristancho is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Code Berryman 3-Series (E36) 7 07-17-2005 12:37 PM
M44 Error Code gzero 3-Series (E36) 0 05-13-2005 05:31 PM
Error Code xxxbimmer 3-Series (E36) 0 04-21-2005 11:26 PM
Error Code Troop705 3-Series (E46, E90) 0 07-16-2004 02:01 PM
need help, error code 50? brycealicious 3-Series (E21, E30) 6 05-27-2004 05:38 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome