My E30 M30 fired for the first time, but something went wrong - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-08-2008, 03:46 AM
n00b
 
Join Date: Jul 2008
Location: JOHANNESBURG, SOUTH AFRICA
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CLI4D is on a distinguished road
Send a message via AIM to CLI4D Send a message via Yahoo to CLI4D
(Thread Starter)
Unhappy My E30 M30 fired for the first time, but something went wrong

Well Guys the day finally came when I had 2 put all my efforts to test. Here's the story cut short.
1. I'm not an expert in engine swaps but i did it, I overhauled the M30 engine by myself and ofcourse with your help guys, thanx alot. A freind gave me a wiring harness with all the injector, and temp connections cut-off n missing.. I had to trace and replace everything, it was a pain.

2. My Baby ran for the first time yesterday well it made a horrible noise due to exhaust manifold (Not yet Installed), because it does not fit due to steering tourching it. It's a right hand Drive, I'll have it custorm made not a problem.

3. Before, All warning lights came On when I switched the key to ON position, Oil pressure, Battery etc.

When the car finally started I noticed the battery Light was still on, I shut the engine OFF, then to ON again (not crank) Battery warning light is OFF, Ran the engine again Battery light ON, now the Engine Harness Light is on as well (not sure off the name). The Light has 6dots and a circle in the middle next to the service indicator. Is this a wiring problem or a bad Alternetor?

Last Q: Starter works fine for a few attemps of crank, then try to start the car again then Starter makes a clicking sound but does not turn the engine over, then i Bridge start the car by putting a screwdriver on the starter terminals, it works fine, after doing this my ignition works normally with the Key for a few attemps, then back to srewdriver stabbing!!

I dont think I'm loosing battery power as i'm NOT doing this for a prolonged period, maybe 5 or 6 trys, and When i swap the battery to my dads BMW E34 the battery fires the car right away, still has alot of power on it.

Thanks for your precious time.. Oh I'll post pics of my swap later during the week cheaz..
CLI4D is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-08-2008, 10:56 AM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
Your starter Solnoid might going bad? maybe try cleaning all the connections....
Nice to hear your doing this swap! any pics? hmmm weird on the alternator sounds kinda like a wiring issue or a really weird failed alternator...

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#3 (permalink) Old 09-09-2008, 01:04 AM
n00b
 
Join Date: Jul 2008
Location: JOHANNESBURG, SOUTH AFRICA
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CLI4D is on a distinguished road
Send a message via AIM to CLI4D Send a message via Yahoo to CLI4D
(Thread Starter)
You're damn right I'll post pics, Thanks alot!
CLI4D is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi Any Ideas why the fuel mix is wrong on my E30? joeK 3-Series (E21, E30) 7 08-30-2007 09:17 PM
M30 E30 JoeMadoo 3-Series (E21, E30) 3 10-05-2006 06:06 PM
Auto Tranny Upshifts At Wrong Time HorsepowerFreak 3-Series (E21, E30) 5 09-02-2005 12:42 PM
BMW M30 from '91 735i into E30 3 series drone 3-Series (E21, E30) 2 07-07-2004 06:09 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome