My ASC Light Won't turn off - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-14-2013, 09:58 AM
n00b
 
Join Date: Jun 2013
Location: San Antonio, TX
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
edsoto84 is on a distinguished road
(Thread Starter)
My ASC Light Won't turn off

Hi all,

I am new to BMW and to this forum. I have a 1997 BMW 528i has 110,000 miles on it. It runs perfectly, the only drawback was I recently had to replace the alternator and battery. The day after these were replaced, I drove it home and all was well. Now, the ASC light has turned on and will not go off. I am not familiar with this engine, but am willing to learn. I have read some threads saying that a broken cable could be the culprit, can anyone else shed some light on this situation? I am willing to try the repairs myself if it is nothing too invasive.

Please help!
edsoto84 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-14-2013, 10:29 AM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
Welcome to Bimmerwerkz.

First double check all the wiring for the battery and alternator and your ground connections. Then I would check all your fuses to make sure they havent blown. After that, if all the connections and fuses look good, I would replace your ASC relay in the fuse box. Mine is orange and says "ASC" in white lettering on it. Yours may be different. When my ABS light was on for a bit, replacing the relay fixed it. They do wear out eventually.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#3 (permalink) Old 06-14-2013, 10:56 AM
n00b
 
Join Date: Jun 2013
Location: San Antonio, TX
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
edsoto84 is on a distinguished road
(Thread Starter)
I will check that and let you know, thank you for the advice!
edsoto84 is offline  
#4 (permalink) Old 06-17-2013, 07:32 PM
n00b
 
Join Date: Jun 2013
Location: San Antonio, TX
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
edsoto84 is on a distinguished road
(Thread Starter)
So, the fuses are all fine, light is still on. I've read some stuff about cleaning the speed sensors or some sensor in the wheel well, any thoughts? Gas mileage is ok, took a trip this weekend and its still giving me what I had pre light
edsoto84 is offline  
#5 (permalink) Old 06-20-2013, 12:11 PM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
What about the relay? Did you replace that? I replaced my relay and the light disappeared.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#6 (permalink) Old 06-20-2013, 12:22 PM
n00b
 
Join Date: Jun 2013
Location: San Antonio, TX
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
edsoto84 is on a distinguished road
(Thread Starter)
What is the relay, and how would I check it?
edsoto84 is offline  
#7 (permalink) Old 06-20-2013, 12:32 PM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
In the fuse box their should be a pink relay. Thats the ABS/ASC relay. If you have a multimeter you can test it, otherwise just replace it. Their not very expensive.

If that fails to solve it, give this a read:
HELP! ASC ABS Problem E39 523i


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
engine won't turn over rudeboyfloyd 3-Series (E36) 4 12-22-2011 01:52 AM
abs light and asc light on 95 325i yama440 3-Series (E36) 0 01-25-2011 09:14 PM
ASC Light always on asc not working?? masesE39 5-Series (E12,E28, E34, E39, E60) 15 01-24-2009 11:29 AM
key won't turn all the way?! booger 3-Series (E36) 1 10-29-2005 07:46 AM
Abs, Asc Lights On And Car Won't Shift vonfittro 5-Series (E12,E28, E34, E39, E60) 1 03-03-2005 06:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome