Indicator Lights - Brake/ABS/ASC-T - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-30-2008, 06:23 PM
n00b
 
Join Date: Jul 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kealamai is on a distinguished road
(Thread Starter)
Indicator Lights - Brake/ABS/ASC-T

Aloooha! I'm new to this BMW site and couldn't find any postings of anyone else having these indicator light problems.

I have a 2000 BMW 528i, and the yellow indicators lights (Brake, ABS, ASC-T)
have all come on. Another weird thing is the same time these lights came on the speedometer and the odometer are not working either. I just recently did an oil change and I reset the oil change lights, could I have done something wrong to trigger this?

I unhooked the battery for a couple minutes and then the indicator lights went away and the speedometer and odometer where working again. What is the issue? Help!!! Is it something I can fix myself?

Kealamai
kealamai is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-31-2008, 02:23 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Cool

if you don't have anymore problems... then it was just a "glitch".

all computer systems get "glitches" sometimes. sometimes from a static charge, sometimes from a current spike, sometimes fom radio frequency even.

Aloha
darkhorse737 is offline  
#3 (permalink) Old 08-01-2008, 12:58 AM
n00b
 
Join Date: Jul 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kealamai is on a distinguished road
(Thread Starter)
Hey Darkhorse737:

When I started the car this morning everything was back to normal with no indicator lights on. But when I drove home from work, the same problem happen. Do you think I need to replace the ABS computer module? I read that it's typical for those to go out in the 2000 5 series. What do you think?
kealamai is offline  
#4 (permalink) Old 08-01-2008, 10:43 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
nope... i suggest you lessen the guesswork before you start replacing parts. (i.e. no point in replacing a module when all that might be necessary is to clean a dirty ABS sensor)

It's cheaper for you to have the car scanned for faults. With or without the lights on, the car computers would have stored the faults in its memory and can be retrieved by a code reader.

Good Luck.
darkhorse737 is offline  
#5 (permalink) Old 08-01-2008, 12:20 PM
n00b
 
Join Date: Jul 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kealamai is on a distinguished road
(Thread Starter)
Thanks Darkhorse737.
kealamai is offline  
#6 (permalink) Old 09-30-2009, 06:13 AM
n00b
 
Join Date: Sep 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pablocruz is on a distinguished road
Aloha to all!!!

I realize I'm picking up this tread over a year later, but I'm having the same problem with the same car ABS and ASC Indicator lights go on etc... what resolved the problem? what was the problem? if you remember, please tell me. Thanks
pablocruz is offline  
#7 (permalink) Old 10-26-2009, 08:38 PM
n00b
 
Join Date: Apr 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWBumper is on a distinguished road
Hi All,

HELP!!! I have a 2000 323i with ~142,000 miles. About three weeks ago, my transmission won't go in reverse. I took my car to a family shop, they said my reverse gear is wore out. So it cost me $2,300 to rebuild it.

I picked up the car and drove it the next morning. As I was waiting at traffic light, I felt like someone push me from the back, this would happened intermittently. Also, when I was cruising at approximately 30mph to 40mph, I felt the gear slipped off intermittently. So I took it back to the shop and they recommended to replace wiring system. But then I have another problem, gear 1, 2 and reverse won't work. The shop ran the diagnostic and they said it is my ABS system. I do see the ABS warning goes on and off sometimes. So they claim that when ABS warning is on, gear 1, 2 and reverse won't work.

Please HELP if you do have advice on how I can get this repair correctly. All reply are much appreciated!!
BMWBumper is offline  
#8 (permalink) Old 10-26-2009, 09:34 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
The OP's issues I believe is the DSC module needs to be rebuilt(Which is a VERY COMMON e38 and e39 issue!)

To BMWBumper: this is a 5 series section you will have better luck in the 3 series section(your's is an e46 chassis)

your car might be going into "limp home mode" where it locks in 3rd gear....when was that last time your batery was changed(Please start a new thead if you havent alredy in the proper section and awnser there)

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS, brake, and ASC warning lights on!? mantoboy 3-Series (E46, E90) 9 02-09-2009 07:54 PM
E39 brake abs and asc light came on ali054 5-Series (E12,E28, E34, E39, E60) 1 04-25-2008 12:02 AM
Abs,asc Lights On + Speedo Not Working ghazanfer 5-Series (E12,E28, E34, E39, E60) 2 06-06-2005 12:55 PM
ABS and ASC lights Henri 3-Series (E36) 10 09-01-2004 02:04 AM
My ABS and ASC lights just turned on... KingScare M-Series (M1, M3, M5, M6) 6 07-06-2004 10:37 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome