Indicator help - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-28-2009, 03:57 PM
n00b
 
Join Date: Mar 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
moonman is on a distinguished road
(Thread Starter)
Indicator help

Help needed, I have 530d series on a 04 plate. My rear offside indicator seems to have a mind of its on. When driving along the idrive will show the indicator not working and it flashes fast as though the bulb has blown. I replaced the bulb, it worked ok for a couple of days, but now shows a fault. I have looked at the connections and they all seem fine, if you bang the inside of the boot, this seems to make the indicator work for a short while, then stops working..... any ideas
moonman is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-28-2009, 04:11 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,697
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
It might be a loose connection. Are you sure the front and side (if so equipped) indicators are working? One out can cause the fast flashing effect.

BMW

Sig by zeaq
witeshark is offline  
#3 (permalink) Old 03-29-2009, 04:01 AM
n00b
 
Join Date: Mar 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
moonman is on a distinguished road
(Thread Starter)
indicator

the front and side are both working,and the rear bulb is good.....
moonman is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Service indicator husks2 3-Series (E36) 8 03-04-2009 02:41 PM
service indicator seanm5915 New Members Check In 1 02-15-2009 09:04 AM
Indicator Problem. Please Help!!!! Privateye 3-Series (E21, E30) 1 06-20-2005 11:21 AM
Indicator Lamps golfatlanta8 3-Series (E36) 0 01-02-2005 01:29 PM
Indicator arms zacspeed 3-Series (E36) 2 07-11-2004 07:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome