Help, Transmission Problems, Help, Help Dealer Is Trying To Take My Mone - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-04-2008, 05:33 PM
n00b
 
Join Date: Feb 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pvalenti99 is on a distinguished road
(Thread Starter)
Help, Transmission Problems, Help, Help Dealer Is Trying To Take My Mone

Maybe someone can help me here I have a 1997 bmw 528i with about 148 thousand miles, on three occasions within the past 7 months while driving my car on the drive position. The transmission would automatically change gears from d to s1 and sometimes s2. and when the car is on park, it would show that itís on s2. I would have this problems for a couple days, and on day 3 the car would go back to normal. And 3 months later I would have the same problems, this usually happens when it snows or rain. So the other when my car was doing that problem, I went to have it put on the computer to find out whats wrong. They told me I would need a turok converter (I am not sure if spelling Is correct) but for some reason I donít really thing thatís the problem, because itís strange like I said it happens like every 3 or 4 months. My brother told me I should just change the transmission oil and see what happen, witch to me make a lot more sense what do you guys think?
pvalenti99 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-04-2008, 09:45 PM
I am Teh Edumacator.
 
Teh Prof's Avatar
 
Join Date: May 2005
Location: ATL, London, and Barcelona
Posts: 4,520
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of Teh Prof has much to be proud of
Send a message via AIM to Teh Prof
If the tranny oil has never been changed, it could very well be dead soon. Those GM transmissions have a rather bad record after 100K miles. Torque converters do also sometimes go bad--mine went bad on my E36 M3.



1999 E39 540i/6-VF Stage 1 S/C, Dinan exhaust, Dinan strut+shock braces, Dinan ltwt flywheel + clutch, Dinan Brembo BBK, Dinan monoball, H&R Springs, Koni Yellows, M5 sways, Dinan forged 18" wheels, &c.

1995 E38 740i. Highly modded. Faster than you.

Sold 2-28-07: 1997 E36 M3/4, 8-30-05 RIP 1997 528i


Lindsay fan club member.
Teh Prof is offline  
#3 (permalink) Old 04-04-2008, 11:06 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
could be the computer...... sounds like a bad connection.... or like when it rains or snows.... water gets into it or something... check the computer see is it is wet or has water / looks like it had water in it....

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#4 (permalink) Old 04-05-2008, 01:10 PM
n00b
 
Join Date: Feb 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pvalenti99 is on a distinguished road
(Thread Starter)
re:

how do i check the computer
pvalenti99 is offline  
#5 (permalink) Old 04-05-2008, 02:32 PM
2nd Gear Member
 
winters97E39's Avatar
 
Join Date: Mar 2006
Location: Jacksonville, FL
Posts: 369
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
winters97E39 is a jewel in the rough winters97E39 is a jewel in the rough winters97E39 is a jewel in the rough
It could be a wheel speed sensor issue. Is your check engine light on, ABS light? I had the same issue, where it was doing this, and the ABS speed sensor was screwed up. those should only cost you about $100 and you can replace them yourself. Just pull a wheel off, and you should see it right there. Have them check for any codes and if there is a speed sensor code, have it replaced. There is one on each wheel. I replaced both my front ones at about 140,000 miles. Since then (I have 162K on it now) i have had zero problems. The issues you described sound alot like what was happening to me. The issue of the display saying you are in S3 when you are in park, or it showing reverse, etc. All of these went away when I put in the new wheel speed sensor. If you havent had one of these replaced yet, its a good starting point of troubleshooting and the least cost. Always, always, always try the easy and cheap stuff first.

Changing the tranny oil is probably a good idea, but make sure you have it done at a shop that knows what they are doing and use the correct transmission fluid. Have the filter replaced as well. I did mine at about 150,000 miles. Although they say its a "lifetime" fluid, I don't really subscribe to that line of thinking.

Jason / 1997 528i
winters97E39 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
transmission problems slick8541sniper@hotmail.c M-Series (M1, M3, M5, M6) 0 11-18-2006 02:54 PM
Transmission Problems ben_t 5-Series (E12,E28, E34, E39, E60) 1 01-18-2005 06:43 PM
Acceleration / Transmission Problems acerche 3-Series (E36) 8 01-07-2005 04:00 PM
transmission problems.. maybe?? akolang 3-Series (E36) 10 02-01-2004 11:11 PM
Transmission problems sb93lx50 5-Series (E12,E28, E34, E39, E60) 0 09-29-2003 07:24 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome