Heater Problem - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-03-2005, 08:34 AM
n00b
 
Join Date: Jun 2005
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bmmf40 is an unknown quantity at this point
(Thread Starter)
1989 E34 535iSE Manual. 248K miles.

Has anyone any ideas on this fault:

Heater blows hot air all the time unless fan is switched off on the heater controls. I then can't get any cold air so I cook in the car! Doesn't matter what settings you select on any of the controls, it stays hot.

Have replaced the Heater control panel, model is the automatic version with seperate left\right edge controls and loads of push buttons.

Heater valves replaced.

Has spent hours hooked up to the BMW diagnostic system at my dealer and they cannot find the faults.

If I isolate the heater valve electrical supply on the valves themselves and feed 12v direct from another source then they switch off OK and the heater core goes cold. Wiring to the valves has been checked using the BMW diagnostic system and is OK.

On the verge of total hair loss over this................ ghead
Bmmf40 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-03-2005, 11:38 PM
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Posts: 1,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute
Quote:
If I isolate the heater valve electrical supply on the valves themselves and feed 12v direct from another source then they switch off OK and the heater core goes cold. Wiring to the valves has been checked using the BMW diagnostic system and is OK.
Well if you supply power to the heater valves and the system goes cold then obviously the system/wiring was NOT checked correctly using the BMW diagnostic system.

The heater valves are powered closed meaning that they should have a constant power and ground present unless the heater is turned on, then the power or gound is taken away (I think ground) and the valve opens because it is built to be sprung open anytime there is no signal present (safety feature)

Sounds like you may want to take it back to whoever you paid to diagnose it and have then recheck it (should probably be free) since you did pay them to diagnose the problem and it sounds like they overlooked this.

Good luck,

DT

DT




Dirty_Tool is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater Problem And Oil Problem floydzeppelinfan 3-Series (E36) 1 04-07-2005 10:19 PM
Need Some Help On Heater Control Unit Problem.. diehard_vue 5-Series (E12,E28, E34, E39, E60) 2 04-06-2005 08:17 PM
Need Help! Problem With Blower, Heater. DiRay 3-Series (E21, E30) 4 02-15-2005 04:13 PM
318IS heater problem jonniwal 3-Series (E36) 1 04-26-2004 12:37 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome