Having some problems with my 97' 540, help! - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-27-2006, 04:11 AM
n00b
 
Join Date: Apr 2006
Location: Phoenix, Arizona
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
uconn299 is on a distinguished road
(Thread Starter)
Having some problems with my 97' 540, help!

I have been driving a 97 540 for around a year now. Bought it with 52,000 miles on it from Dads friend, it was their second car. The car now has just gone over 67,000 and I have noticed a few problems as of late that I assume is going to become more and more common now with age.

1) Noticed recently that the engine seems to be making a rather loud whistling sound. Doesn't always happen but as of late it seems to be happening more and more.

2) Trunk latch is not working. I had problem closing the trunk on a recent trip, it would not latch. I had to manually turn the key and close the trunk in order for it to latch. When I go to press the trunk key on the remote it just makes a clicking sound, I assume it has been broke? Any idea on what the dealership will steal from me on this one, or possibly a DIY fix?

3) I have noticed if I am in park and I put my foot on accelerator I can feel vibration from the exhaust under car. This just happens when I initially apply pressure to pedal. When I am driving it also seems that when I am cruising and slow down I also feel a kind of vibration. Possibly something loose?

4) Last trip to the dealer for an oil change they suggested I replace a rear ball joint. Charge would be $650. Is this common?

I apologize for my ignorance, but when it comes to cars I am clueless. Any help or suggestions would be great.

Thanks, Eric in Arizona
uconn299 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-27-2006, 09:44 AM
cnn
Neutral Member
 
Join Date: Apr 2006
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cnn is on a distinguished road
All of your issues were discussed on the other board

Quote:
Originally Posted by uconn299
I have been driving a 97 540 for around a year now. Bought it with 52,000 miles on it from Dads friend, it was their second car. The car now has just gone over 67,000 and I have noticed a few problems as of late that I assume is going to become more and more common now with age.

1) Noticed recently that the engine seems to be making a rather loud whistling sound. Doesn't always happen but as of late it seems to be happening more and more.

2) Trunk latch is not working. I had problem closing the trunk on a recent trip, it would not latch. I had to manually turn the key and close the trunk in order for it to latch. When I go to press the trunk key on the remote it just makes a clicking sound, I assume it has been broke? Any idea on what the dealership will steal from me on this one, or possibly a DIY fix?

3) I have noticed if I am in park and I put my foot on accelerator I can feel vibration from the exhaust under car. This just happens when I initially apply pressure to pedal. When I am driving it also seems that when I am cruising and slow down I also feel a kind of vibration. Possibly something loose?

4) Last trip to the dealer for an oil change they suggested I replace a rear ball joint. Charge would be $650. Is this common?

I apologize for my ignorance, but when it comes to cars I am clueless. Any help or suggestions would be great.

Thanks, Eric in Arizona

www.bimmerboard.com or

http://bimmer.roadfly.com/bmw/forums/e39/forum.php

Do a search, all these items will come up.

Good Luck
cnn is offline  
#3 (permalink) Old 04-27-2006, 02:25 PM
Sodium Chloride
 
saltshaker185's Avatar
 
Join Date: Feb 2006
Location: Louisville Ky
Posts: 3,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold
Send a message via AIM to saltshaker185 Send a message via MSN to saltshaker185
Quote:
Originally Posted by uconn299
I have been driving a 97 540 for around a year now. Bought it with 52,000 miles on it from Dads friend, it was their second car. The car now has just gone over 67,000 and I have noticed a few problems as of late that I assume is going to become more and more common now with age.

1) Noticed recently that the engine seems to be making a rather loud whistling sound. Doesn't always happen but as of late it seems to be happening more and more.

2) Trunk latch is not working. I had problem closing the trunk on a recent trip, it would not latch. I had to manually turn the key and close the trunk in order for it to latch. When I go to press the trunk key on the remote it just makes a clicking sound, I assume it has been broke? Any idea on what the dealership will steal from me on this one, or possibly a DIY fix?

3) I have noticed if I am in park and I put my foot on accelerator I can feel vibration from the exhaust under car. This just happens when I initially apply pressure to pedal. When I am driving it also seems that when I am cruising and slow down I also feel a kind of vibration. Possibly something loose?

4) Last trip to the dealer for an oil change they suggested I replace a rear ball joint. Charge would be $650. Is this common?

I apologize for my ignorance, but when it comes to cars I am clueless. Any help or suggestions would be great.

Thanks, Eric in Arizona
1) dont count on me but i think it might be the secondary air pump is leaking... accually it could be any air related part leaking in you bay, i would pop the hood and listen for the sound, once you find the point report back here and then maybe we can help you out somemore...

2) before you go out and start buying part, i would sugest looking at it a little more... if the latch is just hard to move then maybe just some greese that you can but from home depot would fix it or some WD-40... if not then personally i would take it out and look into and see if i could figure it out... (maybe a spring popped undone or something?) but since your clueless about cars, maybe get a friend who knows a little more about it to look into it...

3) its probibly just a loose exhaust bracket... If you are the kind that are willing to get under the car and check stuff out, look at all the brackets that are holding the exhaust in place... im willing to bet that it could be fix with a simple twist of a rachet...

4) im not familar with 540's so im not going to sugest anything about the ball joint... 650 sounds pretty steep, id guess alot of that is labor though...

id just spend a little bit more time with your car (have some bonding time haha) and look into these problems that are bothering you... if your lucky it could all be a couple quick fix's and youll be again in no time...
saltshaker185 is offline  
#4 (permalink) Old 04-27-2006, 06:04 PM
4th Gear Member
 
Eric S.'s Avatar
 
Join Date: Oct 2004
Posts: 817
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Eric S. is on a distinguished road
I don't know about the other stuff, but I DO know the deal about rear ball joint, because I replaced my own ball joints in my 1999 540/6. The dealer wanted $700 P&L to change out the ball joints on both sides, and a local BMW indie wanted $600, so your quote of $650 isn't far off.

In reality, total parts cost is under $100 for two new ball joints (getcoolparts.com or alloemautoparts.com). You will need a special BMW rear ball joint press tool that cost me $210 a year ago, a torque wrench that goes to 196 ft-lb, and 22, 21, 18, and 16mm sockets and wrenches. You will also need a Bentley manual and preferably a good how-to write-up. I have one, so if you want it let me know and i can e-mail it to you. I sold the BMW special tool when I was done, so my special tool cost was actually only about $75 net. Total job cost was about $175 or so, plus my time.

With the instructions and proper tools, it took me about 5 hours to do both sides (and I am slow) as compared to the dealer "book" rate for the job of 3 hours per side. It was not a big pain.

<span style='colorurple'>Eric S.</span>
2006 Honda Odyssey EXL-RES
2006 Honda Accord V6 EX-L Sedan
1999 BMW 540i 6-Speed (Sold to M3UOND on 9/21/06)
1991 Honda Civic Si - Occasional Beater
Eric S. is offline  
#5 (permalink) Old 04-27-2006, 11:14 PM
n00b
 
Join Date: Apr 2006
Location: Phoenix, Arizona
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
uconn299 is on a distinguished road
(Thread Starter)
re

Thanks for all the info guys.

For the suggestion about the trunk latch, I might try and take it apart and see if I can fix it. It sounds like it might be jamed. Any info on how to take the thing apart or any sites with some pictures would be a help.

I am pretty clueless when it comes to cars but I can be handy at times. I did change the back tail lights from stock to the new clear tails, however it was a pain in the ass! I also changed the side marker lights which was also very hard, J/K.
uconn299 is offline  
#6 (permalink) Old 04-28-2006, 12:46 AM
5th Gear Member
 
CosmosBlack's Avatar
 
Join Date: Jul 2003
Location: Florida
Posts: 1,282
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute
The whistling sound is probably your oil separator.
It's broken and is causing a vacuum leak.
Soon, you will lose power on acceleration, as it gets worse the engine will stall, and you will get whitish smoke from the exhaust.

CosmosBlack is offline  
#7 (permalink) Old 04-28-2006, 04:57 PM
n00b
 
Join Date: Apr 2006
Location: Phoenix, Arizona
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
uconn299 is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by CosmosBlack
The whistling sound is probably your oil separator.
It's broken and is causing a vacuum leak.
Soon, you will lose power on acceleration, as it gets worse the engine will stall, and you will get whitish smoke from the exhaust.
White smoke or blue smoke? Found this part on ebay and it says blue smoke. http://cgi.ebay.com/ebaymotors/BMW-e...QQcmdZViewItem

Is this a do-it-yourself fix? I am going to bring it into the dealer and see what they say. I have noticed some acceleration lose but can;t see any smoke. This sounds like it might be the problem.

Last edited by uconn299; 04-28-2006 at 05:03 PM.
uconn299 is offline  
#8 (permalink) Old 04-28-2006, 09:59 PM
2nd Gear Member
 
winters97E39's Avatar
 
Join Date: Mar 2006
Location: Jacksonville, FL
Posts: 369
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
winters97E39 is a jewel in the rough winters97E39 is a jewel in the rough winters97E39 is a jewel in the rough
replacing the trunk lock actuator:

http://www.bmwtips.com/tipsntricks/t...20actuator.htm

takes like 10 minutes. They are not that expensive either, like $40 maybe. I cant remember. I had to replace mine too. It worked, but the "trunk" light was always lit up on my dash and it bugged the crap out of me.

Jason / 1997 528i
winters97E39 is offline  
#9 (permalink) Old 04-29-2006, 02:18 AM
n00b
 
Join Date: Apr 2006
Location: Phoenix, Arizona
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
uconn299 is on a distinguished road
(Thread Starter)
re

I hate those damn lights. My display always shows check front fog lights when they are working fine and the dealer also checked. ahhhhh!
uconn299 is offline  
#10 (permalink) Old 04-29-2006, 10:23 PM
Sodium Chloride
 
saltshaker185's Avatar
 
Join Date: Feb 2006
Location: Louisville Ky
Posts: 3,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold saltshaker185 is a splendid one to behold
Send a message via AIM to saltshaker185 Send a message via MSN to saltshaker185
Quote:
Originally Posted by uconn299
I hate those damn lights. My display always shows check front fog lights when they are working fine and the dealer also checked. ahhhhh!
are they aftermarket? cheapo lights will often give the wrong resistance and throw off the sensor thinking the lights are blown...
saltshaker185 is offline  
#11 (permalink) Old 05-01-2006, 03:39 PM
n00b
 
Join Date: Apr 2006
Location: Phoenix, Arizona
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
uconn299 is on a distinguished road
(Thread Starter)
re

No they are orginal stock fog lights.
uconn299 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
serious problems with E34 540, please help antose9 5-Series (E12,E28, E34, E39, E60) 4 11-05-2009 07:02 PM
540 or 530 draven1018 5-Series (E12,E28, E34, E39, E60) 9 11-24-2005 04:36 PM
E36 Overheating / Head Problems Sean Duggan 3-Series (E36) 7 10-05-2005 05:45 AM
Climate Control Problems black318 3-Series (E36) 0 02-24-2005 02:00 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome