fixed new loss of power problem 520i - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-21-2007, 02:24 PM
n00b
 
Join Date: Nov 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
garry62be is on a distinguished road
(Thread Starter)
fixed new loss of power problem 520i

after checking all vac pipes,cleaned icv,replaced fuel pump(faulty)still had lack of power.then did a good search and you need to look at the two black power cables pass/side by brake servo follow them down you should then feel large metal pipejust to the right and bellow the icv,on this are two elctrical connectors am sure one is ground earth to the coils,mine had come off and car suddenly had bad idle,stall etc.hope this helps
garry62be is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-05-2007, 03:56 AM
n00b
 
Join Date: Nov 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
garry62be is on a distinguished road
(Thread Starter)
all probs gone

found out after going to bmw hereford paid £25 for check,it was my camshaft sensor makeing car go like a dead donkey so bought new sensor off them for 374 PUT IT IN MYSELF AND BACK TO FULL POWER
garry62be is offline  
#3 (permalink) Old 12-05-2007, 05:27 AM
n00b
 
Join Date: Nov 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
garry62be is on a distinguished road
(Thread Starter)
Got It On Computer At Bmw £25 Told Me Camshaft Sensor Had Gone,i Orderd It £74 Then Put It In Myself Only Takes 5 Mins Car Back To Full Power
garry62be is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sputtering / Loss Of Power streetdreams 3-Series (E36) 9 02-18-2005 03:35 PM
325 TDS Power Loss pandy525 3-Series (E36) 4 09-09-2004 11:05 AM
Power LOSS skawful 3-Series (E36) 4 08-09-2004 07:56 AM
Power Window problem? relay? buckeye74 3-Series (E36) 4 12-08-2003 01:53 AM
power window problem bimmmer 3-Series (E36) 2 09-21-2003 06:41 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome