Electrical Problem AC Stereo - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-17-2004, 07:04 AM   #1 (permalink)
n00b
 
Join Date: Jul 2004
Car:
Posts: 5
Photos:
byttcool is an unknown quantity at this point
Hello All,

have a 528i 98 model with electrical problems for example: stereo screen sysytem suddenly turns off the after an hour or so the phone gives a beep and the stereo screen starts working again.

also the airconditionng suddenly stopped working and then it turns back on alone

Please reply, experts.
byttcool is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-18-2004, 04:09 AM   #2 (permalink)
n00b
 
Join Date: Jul 2004
Car:
Posts: 5
Photos:
byttcool is an unknown quantity at this point
none knows............
byttcool is offline   Reply With Quote
Old 07-19-2004, 01:24 AM   #3 (permalink)
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Car:
Posts: 1,052
Photos:
Dirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond repute
do you have navigation? if not then by the stereo screen i would assume you mean the MID. If so it may be an early SW MID and may need to be replaced with an updated unit. When it goes blank do you still get sound? when the AC turns off does it just lose fan speed? or does the actual AC quit. If its just fan speed it could possibly be a bad final stage. Another symptom of this would be intermittent erratic fan speed. Getting back to the radio concern are there any other symptoms? when opening the sunvisors do you get any ligjhts flickering on the dash? If so this could indicate a bad ground or a faulty ignition switch. Let us know some more details if u need more help. Hope this helps some.
__________________
DT




Dirty_Tool is offline   Reply With Quote
Old 07-19-2004, 05:57 AM   #4 (permalink)
n00b
 
Join Date: Jul 2004
Car:
Posts: 5
Photos:
byttcool is an unknown quantity at this point
Thanks,,,,,

Answer:
NO Navigation.
No sound when screen goes,
The AC just loose the cold air, the fan and airflow maintained the same power.
When the radio turns off the only button that works is the time button and the screen lights up with the time.
No flickering of screen when sunvisors are down.
byttcool is offline   Reply With Quote
Old 07-19-2004, 10:46 PM   #5 (permalink)
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Car:
Posts: 1,052
Photos:
Dirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond repute
Hey again,
On the radio/MID problem the only info I could find was for earlier production date vehicles so in your case it will have to be troubleshot by a technician hands on. I would suspect a faulty MID or radio.

On the A.C does it cut out when your sitting at a stop? If so it could be that the auxillary fan is not working. (electric fan in front of the AC condenser) Check and ensure that it is working. Beyond that it could be anything...most likely would need to be troubleshot hands on as well.

Sorry i couldnt be of more help, Good Luck
__________________
DT




Dirty_Tool is offline   Reply With Quote
Old 07-26-2004, 09:13 AM   #6 (permalink)
n00b
 
Join Date: Jul 2004
Car:
Posts: 5
Photos:
byttcool is an unknown quantity at this point
byttcool is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need The Experts-mysterious Electrical Problem??? JonnyM3 3-Series (E36) 6 12-06-2004 07:04 PM
strange electrical problem diadpaku 5-Series (E12,E28, E34, E39, E60) 7 11-09-2004 06:19 PM
Electrical Problem? akrauss 3-Series (E46, E90) 14 08-11-2003 03:43 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:04 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.