E39 radio not working - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-07-2009, 03:18 PM   #1 (permalink)
n00b
 
Join Date: May 2009
Car:
Posts: 5
Photos:
fahdp is on a distinguished road
E39 radio not working

Hi
Need some help with my radio. Its doesn't work at all. No power, no display just does not switch on. Tried the CD changer as well, and it does not even eject the cartridge. Seems like no power there also.

I have checked the fuses in glove box and boot, and they all seem fine. Anyone have any ideas?

Thought I might add that the battery died and by mistake when jumping the car, mechanic connected jump leads the other way round so there were sparks ( i.e postitve on negative terminal etc ) all be it for a few secs before he realised mistake. All other electrics work fine though, just the radio and changer.

Thoughts appreciated
fahdp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-08-2009, 08:33 AM   #2 (permalink)
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Car: 97 540IA, 95 840CI
Posts: 863
Photos:
LOS is an unknown quantity at this point
If I'm not mistaken some radios required a code to activate after being removed or in your case a "short".

LOS
LOS is offline   Reply With Quote
Old 05-08-2009, 08:40 AM   #3 (permalink)
n00b
 
Join Date: May 2009
Car:
Posts: 5
Photos:
fahdp is on a distinguished road
how would you activate it if it does not even power up?

Do you just enter the code when its off and it somehow powers it?
fahdp is offline   Reply With Quote
Old 05-08-2009, 02:31 PM   #4 (permalink)
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Car: 97 540IA, 95 840CI
Posts: 863
Photos:
LOS is an unknown quantity at this point
There has to be a fuse behind the radio unit. Have you pulled the radio out?

LOS
LOS is offline   Reply With Quote
Old 05-11-2009, 03:47 AM   #5 (permalink)
n00b
 
Join Date: May 2009
Car:
Posts: 5
Photos:
fahdp is on a distinguished road
that the next thing i'm going to try, just need some time!! Any ideas where behind the radio unit?
fahdp is offline   Reply With Quote
Old 05-11-2009, 09:12 AM   #6 (permalink)
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Car: 97 540IA, 95 840CI
Posts: 863
Photos:
LOS is an unknown quantity at this point
Usually is on the back of the unit itself. The next thing would be to have it tested at a repair shop. If the unit is bad you can purchase one from ebay or a junkyard.

LOS
LOS is offline   Reply With Quote
Old 05-16-2009, 06:25 AM   #7 (permalink)
n00b
 
Join Date: May 2009
Car:
Posts: 5
Photos:
fahdp is on a distinguished road
OK finally got to remove the headunit. Checked the fuse. Indeed it was gone. Changed it with another new 10Amp fuse. However radio unit still does not switch on at all. CD changer in the boot also does not work ( still cant eject cartridge ).

Im beginning to think that perhaps unit is blown, but not sure. Ideas?
fahdp is offline   Reply With Quote
Old 05-18-2009, 09:14 AM   #8 (permalink)
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Car: 97 540IA, 95 840CI
Posts: 863
Photos:
LOS is an unknown quantity at this point
Try disconnecting the battery for ten minutes and see what happens...

LOS
LOS is offline   Reply With Quote
Old 05-18-2009, 09:28 AM   #9 (permalink)
n00b
 
Join Date: May 2009
Car:
Posts: 5
Photos:
fahdp is on a distinguished road
Thanks but got it sorted now. After I changed fuse in radio unit and it still wouldnt power up, I removed the CD changer and changed that fuse as well.

That fixed the issue, both work now! Phew. Many thanks for pointing me in the right direction. Am still confused as to why only after changing both fuses it worked, I assume they must be sharing power.

Anyways sorted!
fahdp is offline   Reply With Quote
Old 05-19-2009, 08:47 AM   #10 (permalink)
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Car: 97 540IA, 95 840CI
Posts: 863
Photos:
LOS is an unknown quantity at this point
Electronics on these cars are in a pain in the ass!
I'm glad things worked out

LOS
LOS is offline   Reply With Quote
Old 02-16-2010, 04:49 AM   #11 (permalink)
n00b
 
Join Date: Oct 2008
Car:
Posts: 17
Photos:
dimbim is on a distinguished road
How did you remove the radio panel?, I am having real trouble.
dimbim is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Not Working Help? MYBEEMER 5-Series (E12,E28, E34, E39, E60) 7 02-16-2010 05:06 AM
Radio not working! jayy781 New Members Check In 1 02-28-2009 03:50 AM
Radio Not Working? HoFF 3-Series (E21, E30) 4 06-26-2005 04:47 PM
Radio Quit Working jay fleischmann Audio and Electronics 6 01-20-2005 06:31 PM
Radio aerial not working :( alexander 5-Series (E12,E28, E34, E39, E60) 3 08-22-2004 02:40 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:11 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.