E39 98' 528i CCV, exhaust, O2 sensor & fault code issues - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-14-2012, 10:21 PM
n00b
 
Join Date: Jun 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Heckler is on a distinguished road
(Thread Starter)
E39 98' 528i CCV, exhaust, O2 sensor & fault code issues

I recently purchased this car and trying to work the gremlins out.
1) It had the signs of a failed CCV so I replaced it with an OEM unit and lower return hose. The upper hose had a small hole in it but was not in stock. I put several rounds of electrical tape around the hose until the new one arrives. Problem is the new CCV solved the smokey start up for about 2 days and now has the same symptoms. I'm hoping the upper hose is the problem but concerned because the temp repair I made on it seems to holding up well. There were no signs of any clogs at the dipstick return.
2) The P.O. had a complete exhaust system replacement just before he sold it. Problems occur here because it is not really a model specific replacement. The system only has 1 cat with the O2 sensor coupling plugged off and no sensor in sight. Should I keep the new exhaust and get O2 similators? I can order a new sensor but will still nowhere to install the 2nd sensor.
3) Faults from Autozone read:
P0141 - Bank 1 sensor 2 (probable cause -poor(probable cause -poor electrical connection) electrical connection)
P0161 - Bank 2 sensor 2 (probable cause -poor electrical connection)
These are obvious why they are throwing a fault code
P0170 - Bank 1 sensor 1, large vacuum leak on engine (probable cause -faulty fuel pressure regulator, low or high fuel pressure, ignition or fuel injector fault
P0173 - Bank 2 sensor 2 . Same explanations as above.
I'm assuming these need to be replaced but should I wait to confirm the CCV issues first?
P1250 - BMW spec ?

Overall the car has 155,000 miles, recent valve cover gasket, starts just fine, idles just fine. It seems to be a sluggish from 0-30 mph but no misfires etc.
Heckler is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
98 528i 2.8L Code 65 Cam Sensor adanjones 5-Series (E12,E28, E34, E39, E60) 0 02-09-2011 07:37 PM
Fault Code: Camshaft Sensor kvadgama 3-Series (E36) 4 11-17-2008 11:23 PM
fault code 1221 issues need ideas seven 3-Series (E36) 1 04-22-2007 10:57 AM
97 528i Fault Code 420 cw_cannon 5-Series (E12,E28, E34, E39, E60) 6 01-01-2005 08:52 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome