E39 540i Transmission problem - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-13-2010, 04:03 AM   #1 (permalink)
n00b
 
Join Date: Apr 2010
Car:
Posts: 4
Photos:
Adil is on a distinguished road
E39 540i Transmission problem

Hi everyone , i have a 2001 E39 540i has a problem of delay shifting the gears .. which mean it shift the gears when the RBM reach 4 (4000 r/min) .. i chang the gear box twis and the problem still the same .. can anyone advice plz..

Last edited by Adil; 04-13-2010 at 04:08 AM.
Adil is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2010, 05:52 AM   #2 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Welcome to the Werkz.

Strange issue, given that you have changed the tranmission twice already, is it possible that it is stuck in Sports mode?
When it changes gears, is it smooth?
Does it have any issues with selecting gears?
Does it go through the gears in manual mode ok? Is there any difference between the D mode and S Mode positions?
brettski is offline   Reply With Quote
Old 04-13-2010, 07:26 AM   #3 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
One of three things.
1) Sotware issue in the EGS....BMW main dealer will rectify this.

2) Are you using the same Valve Control body fromthe original box.

3) fluid level is to low.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 04-13-2010, 10:52 PM   #4 (permalink)
n00b
 
Join Date: Apr 2010
Car:
Posts: 4
Photos:
Adil is on a distinguished road
Quote:
Originally Posted by brettski View Post
Welcome to the Werkz.

Strange issue, given that you have changed the tranmission twice already, is it possible that it is stuck in Sports mode?
When it changes gears, is it smooth?
Does it have any issues with selecting gears?
Does it go through the gears in manual mode ok? Is there any difference between the D mode and S Mode positions?
thanks for reply..

first when i drive the car its changes the gears normaly but i think when its worm or when i go on highway it become like this. and when i change to manual mode when i change to 4th gear it come back to 3rd gear again and in the highway i change to 5th it come back to 4th but it some times it gose normaly in the highway and change to 5th gear by it self ..

and no difference between D mode and S mode when this issue shows..
Adil is offline   Reply With Quote
Old 09-16-2010, 07:25 AM   #5 (permalink)
n00b
 
B-Con's Avatar
 
Join Date: Sep 2010
Car: 2003 BMW 540i M-Sport
Posts: 2
Photos:
B-Con is on a distinguished road
.
Did you ever find a solution to your problem? I'm having the same.
B-Con is offline   Reply With Quote
Old 09-28-2010, 02:15 PM   #6 (permalink)
n00b
 
B-Con's Avatar
 
Join Date: Sep 2010
Car: 2003 BMW 540i M-Sport
Posts: 2
Photos:
B-Con is on a distinguished road
Solved.

Although my car never gave me any messages or error codes, it seemed like the transmission was going into a fail-safe mode. My guess was that the transmission was overheating.

I replaced the transmission cooler (heat exchanger), and that fixed the problem.
B-Con is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
540i E39 transmission ray barter 5-Series (E12,E28, E34, E39, E60) 5 12-22-2010 09:17 AM
e39 transmission problem ys5901 5-Series (E12,E28, E34, E39, E60) 6 07-18-2007 05:43 AM
2001 540I Transmission Problem dukesmg 5-Series (E12,E28, E34, E39, E60) 1 09-12-2005 07:28 PM
E39 540i Ticking Problem HardStep 5-Series (E12,E28, E34, E39, E60) 2 08-17-2005 08:09 PM
E39 Transmission Problem? C-Note M-Series (M1, M3, M5, M6) 2 11-13-2004 05:25 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:16 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.