E39 530d Touring EBS? Problems - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-08-2010, 07:04 AM   #1 (permalink)
n00b
 
Join Date: Nov 2010
Car:
Posts: 2
Photos:
Andy1949 is on a distinguished road
E39 530d Touring EBS? Problems

Hi, please bear with me as I'm a newbie and would like to ask your advice on a problem I have with my E39 that I have recently purchased.

Firstly I do know that it was previously involved in a front end collision (no damage to chassis and panels replaced).

I'll try to explain the problem best I can.

Known permanent faults with car.
1. EBS switch doesn't appear to work (light doesn't illuminate when switch is pressed)
2. Parking sensors don't work

Driving along, everything OK, all other electrics working fine (speedometer, odometer, vacuum, temp, av. mpg, av. mph, cruise control etc.) with no warning lights on dash.

The following happens only after I have to "jab" on the brakes (not hard braking just a quick "jab", sometimes it happens at the junction at the end of my road (200 yards), other times when leaving a motorway at 100-200 miles away from home!

Firstly the ABS "seems" to operate, I hear what I can only describe as a metallic springy "boing boing" sound and I can feel it through the brake pedal although the brakes don't lock and the car reduces speed smoothly with no juddering (the pads are OK and there is only slight wear on the discs).

Shortly afterwards (not immediately but within 1-2 mins) the EBS and anti-lock lights come on.

Then shortly afterwards on the majority of occasions (but not always)
1. The speedometer GRADUALY falls to zero.
2. The vacuum gauge swings across to the left (50+mpg)
3. The fuel gauge falls when accelerating or rises when braking.
4. The odometer and mileage trip don't work.
5. The fuel trip (mileage left) goes up and down the same as the fuel gauge (reduces when accelerating, increases when braking).
6. The temp gauge reads -5 deg C
7. The av. mpg & mph don't work, they both permanently show single figures for both (not correct) but I believe that this is due to the above problems.

At the moment I'm using a sat nav for my speedo and apart from the above the car runs fine. The noise "boing boing" from the brakes only seems to occur prior to the onset of the above, afterwards all is fine.

Lastly after I have stopped, locked up, and then restarted the car, everything works again.

Any help or suggestions would be gratefully appreciated.

Many thanks, Andy
Andy1949 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-08-2010, 09:09 AM   #2 (permalink)
n00b
 
Join Date: Nov 2009
Location: Norway
Car: E28 and e39
Posts: 48
Photos:
ealoken is on a distinguished road
Sounds like a ABS sensor left rear..
__________________
E28 rebuild project.

The goal is 500 whp... street legal.
ealoken is offline   Reply With Quote
Old 11-08-2010, 10:06 AM   #3 (permalink)
n00b
 
Join Date: Nov 2010
Car:
Posts: 2
Photos:
Andy1949 is on a distinguished road
Hi, I'm hoping you are right I can't really afford a new ABS module.

Many thanks, Andy
Andy1949 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E39 530d Amp Location !?? Help!! WAVEMAN 5-Series (E12,E28, E34, E39, E60) 12 10-22-2013 11:49 AM
bmw 530d starting problems rgallagher1234 5-Series (E12,E28, E34, E39, E60) 3 09-02-2010 03:47 PM
Nothing but Problems with 530D rmayo 5-Series (E12,E28, E34, E39, E60) 7 02-15-2010 02:52 AM
530d E39 ( DDE ) light dirty diesels 5-Series (E12,E28, E34, E39, E60) 9 11-26-2008 09:48 PM
e39 530d smooth 5-Series (E12,E28, E34, E39, E60) 0 07-09-2006 11:51 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:04 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.