:E39 528 not going into 5th gear - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-10-2012, 05:45 AM   #1 (permalink)
n00b
 
Join Date: Jun 2011
Location: South Africa
Car: Its a 1996 BMW 528i Auto
Posts: 4
Photos:
Iceman528i is on a distinguished road
:E39 528 not going into 5th gear

I had my gearbox done because it was slipping and now that i have it back it doesnt go into 5th gear, the gearbox place replaced 5 valve boddies in the box and he recons the gearbox is mechanically sound. When in 3rd gear you must go just over 60km/h and release the accelerator cable a bit before it changes to 4th but doesnt go into 5th at all. The ASC light has also been on since i have it back? Ive read threads that it may be wheel sensors that are faulty? I had it by the agents and the fault code 100 speed monitoring comes up. They also say that gearbox is faulty. The gearbox place says they will put another box in but if it does the same they will charge me labour costs for it which i really dont want as i have spent too much money already on this problem. When it came back from the dealers only the speedometer was working and none of the other gauges, dont know if all this is connected in any way? Could someone please give me any advice as to get the box changed or have sensors etc checked?
Iceman528i is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-10-2012, 04:46 PM   #2 (permalink)
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Car: 1998 E36 328i
Posts: 2,210
Photos:
Lord Vader is on a distinguished road
Auto or Manual?

First off, i would take it back to the shop and tell them to eat the labour charge as they fixed it and its not working. Not sure how it works where you live, but if they said they would fix the gearbox and its not working then they didnt really fix it did they?

The speed sensor is located in the rear differential. The guages may not be working because a connector has come loose. Have you had the OBD system scanned for codes?
__________________

ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline   Reply With Quote
Old 06-10-2012, 05:22 PM   #3 (permalink)
n00b
 
Join Date: Jun 2011
Location: South Africa
Car: Its a 1996 BMW 528i Auto
Posts: 4
Photos:
Iceman528i is on a distinguished road
Its a 5spd automatic. GM box they say. BMW agents gave fault code 100 speed monitoring.
Iceman528i is offline   Reply With Quote
Old 06-10-2012, 08:04 PM   #4 (permalink)
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Car: 1998 E36 328i
Posts: 2,210
Photos:
Lord Vader is on a distinguished road
Thats an odd code. All OBD-II codes are 5 digit codes. Shown as "P0215" for example. Take it to an auto parts store or somewhere that does OBD code scanning. Most auto parts stores do it for free.
__________________

ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline   Reply With Quote
Old 06-11-2012, 01:10 PM   #5 (permalink)
n00b
 
Join Date: Jun 2011
Location: South Africa
Car: Its a 1996 BMW 528i Auto
Posts: 4
Photos:
Iceman528i is on a distinguished road
I took the car back to the shop today and they phoned me later to tell me the torque converter must be replaced cause its noisy(funny they didn't notice that the first time around) Duno if that could be the problem but anyway ill hear what they say tomorrow and keep you posted. Thanks for the replies.
Iceman528i is offline   Reply With Quote
Old 06-14-2012, 01:15 PM   #6 (permalink)
n00b
 
Join Date: Jun 2011
Location: South Africa
Car: Its a 1996 BMW 528i Auto
Posts: 4
Photos:
Iceman528i is on a distinguished road
Well it mustve been the torque converter because its 100% now. Now just for the instruments. Where or what connecter do you think couldve came loose? Ive checked the fuses and they are fine. Cant think why if bmw did a diagnostic test the cars cluster wont be working. Its the radio aswell as the temp and heat gauge and the rev counter. The speedometer is fine. Luckily for the range i can see how much petrol i have in.lol. Think i should try disconecting the battery for a while? only other thing i can think of is that after they work on the car it goes to the washbay so maybe something got wet somewhere?
Iceman528i is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
gear box drops out of gear at low revs on a e36 daniel morgan 3-Series (E36) 0 02-04-2011 02:04 AM
m3 csl on Top Gear Trob 3-Series (E36) 3 12-19-2005 10:47 PM
Why Not Another Gear On E36? RedlinedRU 3-Series (E36) 13 11-14-2004 10:07 PM
gear Rich328 3-Series (E36) 2 06-19-2004 07:35 PM
3rd gear BllnLkeRayFelton 5-Series (E12,E28, E34, E39, E60) 2 05-02-2004 02:01 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:53 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.