E39 1999 528i Speedometer problem - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-21-2004, 07:03 PM
n00b
 
Join Date: Jun 2004
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
vinny is an unknown quantity at this point
(Thread Starter)
Cool

Hi forum members,

I'm a newbie here. Last week I ran into the following problem:

(1) Yellow Warning light is on. ABS (red) light is on.
(2) Speedometer is 0.
(3) Tachometer is running fine
(4) Trip Odometer is stopped

I read somewhere that there's a circuit either in the front or rear wheel for determining the speed of the vehicle. Does it look like that's the root of the problem?

Thanks in advance for any advice.

Vinny
vinny is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-23-2004, 09:41 PM
n00b
 
Join Date: May 2003
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kowached is an unknown quantity at this point
Sounds like you lost an ABS sensor. I beleive the Right Rear sensor is the primary input for speed, so check there first, but it could be any of them. It could be a bad sensor, the wire that runs along the suspension could be damaged, and the its VERY common for the plastic box where the connector is located (behind the plastic wheel well) to be full of dirt and debris which traps moisture and corrodes the wire/connector.

Later,
Dave

E39 - 1998 540iA Sport (11/97 Production)
E30 - 1989 M3 (44k miles)
1979 Triumph TR7, still have my first car ;-)
Past cars:
E21 - 1980 320i (sold at 130k)
E23 - 1986 735i
I am a BMW Car Club of America member, are you? <a href='http://www.bmwcca.org/' target='_blank'>http://www.bmwcca.org/</a>
<img src='http://members.roadfly.com/kowached/bmwcca1.gif' border='0' alt='user posted image'>
kowached is offline  
#3 (permalink) Old 06-23-2004, 10:00 PM
You Can Has A Custom Title!!
 
e36_m3_Turbo's Avatar
 
Join Date: Jan 2003
Location: Seattle, Washington
Posts: 5,253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute e36_m3_Turbo has a reputation beyond repute
yes the sensor is in your rear diff. its a wire that plugs into the casing.

<img src="http://i4.photobucket.com/albums/y149/QnRainStar/e30-blackangus032.jpg" alt="Image hosted by Photobucket.com">

No longer red.
e36_m3_Turbo is offline  
#4 (permalink) Old 06-23-2004, 11:29 PM
n00b
 
Join Date: May 2003
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kowached is an unknown quantity at this point
Maybe on the E36 its in the rear diff, the E39 has ABS sensors at each wheel hub.

Later,
Dave

E39 - 1998 540iA Sport (11/97 Production)
E30 - 1989 M3 (44k miles)
1979 Triumph TR7, still have my first car ;-)
Past cars:
E21 - 1980 320i (sold at 130k)
E23 - 1986 735i
I am a BMW Car Club of America member, are you? <a href='http://www.bmwcca.org/' target='_blank'>http://www.bmwcca.org/</a>
<img src='http://members.roadfly.com/kowached/bmwcca1.gif' border='0' alt='user posted image'>
kowached is offline  
#5 (permalink) Old 06-24-2004, 01:30 PM
n00b
 
Join Date: Jun 2004
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
vinny is an unknown quantity at this point
(Thread Starter)
Cool

I'll take a look at that then ... is it easy to access to the sensor?

Thanks!

vinny is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
528i Alarm Problem Xero 5-Series (E12,E28, E34, E39, E60) 5 01-03-2011 02:16 PM
Considering Buying A 1999 528i qwerty12 5-Series (E12,E28, E34, E39, E60) 2 08-02-2005 04:58 PM
Carfax Please? jschoenfeld 5-Series (E12,E28, E34, E39, E60) 1 05-11-2005 09:36 AM
E39 (1999) Radio Problem, Please Help anandvardhan Audio and Electronics 3 01-16-2005 10:31 AM
99 528i wad06 5-Series (E12,E28, E34, E39, E60) 5 12-11-2004 02:59 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome