e34 auto box issue, no power and not changing gear ?? - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-26-2013, 09:29 PM
n00b
 
Join Date: Jun 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BkkBMman is on a distinguished road
(Thread Starter)
e34 auto box issue, no power and not changing gear ??

Hi guys,

I was wondering if you can help. I just picked up a e34 last night with an M50B25 engine in it. engine runs ok. little but rough, probably just needs a service as the car has been sitting for a while. But the gearbox seems to be stuck in one gear. it doesnt matter if you use gear D, 1,2,3 it feels the same and drives the samein all gears. its got NO POWER what so ever. feels like pulling off in 3rd gear if it was a manual. it finally gets up to about 80kms/h at around 3000+rpm. and doesnt change gear at all. although after buying the car and driving around 40kms it started to change gear sometimes but still low end power was completely non existant.

last night by the time i got it home it was changing gears at low speed but still crazy underpowered. the engine revs fine in neutral.

this morning it was back to not changing gear.

Any ideas what i can try and or check. I was thinking to initially just change the gearbox oil and filter and see what happens but any advise would be greatly appreciated.

Also what gear oil should I use for the gearbox and what gear oil should I use for the diff?

Thank guys...
BkkBMman is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-01-2013, 12:48 PM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
The transmission may need replacement. The transmission has solenoids that can fail over time causing the transmission not to shift out of the gear its in.

On the bottom of the transmission pan will be a sticker. If its green then it uses Dexron III. Diff is normally 75w-90 i believe.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#3 (permalink) Old 07-03-2013, 12:00 AM
n00b
 
Join Date: Apr 2010
Location: Honolulu, Hawaii
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Synesthesia is on a distinguished road
Lord Vader is correct

Welcome to the infamous slush box problems for e34.

Once you have it overhauled with new components you will LOVE your car.
Synesthesia is offline  
#4 (permalink) Old 07-14-2013, 03:48 AM
n00b
 
Join Date: Jun 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BkkBMman is on a distinguished road
(Thread Starter)
hi guys, I have taken the gearbox sump pan off, cleaned inside and replaced the auto box filter. the gearbox is a japanese gearbox. not what I was expecting. I was told his a z co box of something. It now changes gear ok but when cold seems to slip a bit. as it gets warm seems to work better. then last night after going to the car wash it was stuck back in one gear. this morning its working again. The other day I had a trans problem error message but thats gone now. Do you think it could be the autobox ecu or do you think the gearbox needs replacing.

Please let me know what you guys think.

Thanks again...
BkkBMman is offline  
#5 (permalink) Old 07-15-2013, 09:56 AM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
What was the markings on the transmsion? Should have had a stamp or tag on the side that would have helped identify the type and manufacturer.

If its stil getting stuck in one gear a solenoid may have failed. If its still slipping it may need to be replaced. A qualified transmission shop will be able to identify the problem.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#6 (permalink) Old 07-16-2013, 05:47 PM
n00b
 
Join Date: Apr 2010
Location: Honolulu, Hawaii
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Synesthesia is on a distinguished road
Just venting.

I love driving my e34. Once I had the trans RRR, now I realized all the BMW hype. My cousin, who owns a trans shop, scolded me for purchasing this car eventhough it had only 100,000 miles at that time. The e34 automatic trans is also found in the isuzu and other makes. I was surprised when he told me that. Another BMW shop here in Honolulu told me to add transmission fluid at a the specific temperature . . . yadayadayada.

Lord Vader, thank you. I wish I joined this form before I purchased my e34.

BK, Best of luck in repairing your trans. Don't forget to change sparkplugs with your new trans. Your car will love it.
Synesthesia is offline  
#7 (permalink) Old 07-17-2013, 09:14 AM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
Quote:
Originally Posted by Synesthesia View Post
I love driving my e34. Once I had the trans RRR, now I realized all the BMW hype. My cousin, who owns a trans shop, scolded me for purchasing this car eventhough it had only 100,000 miles at that time. The e34 automatic trans is also found in the isuzu and other makes. I was surprised when he told me that. Another BMW shop here in Honolulu told me to add transmission fluid at a the specific temperature . . . yadayadayada.

Lord Vader, thank you. I wish I joined this form before I purchased my e34.

BK, Best of luck in repairing your trans. Don't forget to change sparkplugs with your new trans. Your car will love it.
The auto trans is made by GM in France and is also found in the Izuzu Rodeo. The transmission needs to be warmed up to operating temperature before draining the fluid. 100,000 miles is minimial if its taken care of properly.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
#8 (permalink) Old 08-07-2013, 07:34 AM
n00b
 
Join Date: Jun 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BkkBMman is on a distinguished road
(Thread Starter)
Hey Guys, Ok, ive finally changed the gearbox. no more slipping but still not changing gear. so i replaced the autobox ecu. the one behind the speaker on the drivers side foot well. it now changes gear but seems very jerky. Like when it changes gear it jumps. I was told that I need to reset everything by taking the battery out for 30 minutes and it will all reset. Ive just taken the positive terminal off and will try it in the morning. Is this true or does this sound like another problem? do you think it could be the gearbox I replaced? or the ECU? or a sensor?

Another thing, on the dash where it says what gear you are in and S/E/* sometimes these two lights go out? is this a problem? and what would it relate to? like should i be worried. Ive only got 7 days guarantee with the gearbox and the ECU so need to get it sorted as soon as i can.

Also I have a new problem to keep me busy. When I put my foot down and the car accelerates there is a really bad vibration and sometimes a bit of a bang sound coming from the rear. it doesnt sound or feel good. could this be a diff mount or something? any ideas guys?

oh and one more thing. I get an error message on the dash saying suspension stabilization or something like that? does this mean i need new shocks or is this something else?
THanks again for all your help...

Last edited by BkkBMman; 08-07-2013 at 07:39 AM.
BkkBMman is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
gear box drops out of gear at low revs on a e36 daniel morgan 3-Series (E36) 0 02-04-2011 02:04 AM
Please help! E34 520i problems starting then auto box goes into limp????? gregs07 New Members Check In 0 11-19-2009 01:56 PM
E34 Zf gear box swap plug difference beelzebubs FAQ's and DIY's 0 06-03-2008 08:42 AM
Need help with auto Gear box SweetflavaUK 3-Series (E21, E30) 0 09-02-2004 07:42 AM
520I SE Auto Gear Box Oil Refill? Ragamuffin Brian 5-Series (E12,E28, E34, E39, E60) 0 04-11-2004 07:11 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome