E34 540 running bad - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-03-2009, 10:48 AM
n00b
 
Join Date: May 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeroen_e34 is on a distinguished road
(Thread Starter)
E34 540 running bad

Hi, I'm new at this forum.
I'm from The Netherlands and own a E34 540I 94.
My car developed the following problem.
At revs above 4500 the engine cuts completely out like there is a rev limiter. It picks up at 4000 rpm again, and when throttle is kept down it will do this continuously. It does this in every gear and also when in park.

Please help

Regards

Jeroen
jeroen_e34 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-03-2009, 11:27 AM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
I believe I'd start with an engine code reading.

BMW

Sig by zeaq
witeshark is offline  
#3 (permalink) Old 05-03-2009, 12:03 PM
n00b
 
Join Date: May 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeroen_e34 is on a distinguished road
(Thread Starter)
No fault codes found
jeroen_e34 is offline  
#4 (permalink) Old 05-03-2009, 12:13 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Is the original engine management chip in place? Have there been any modifications to any engine systems?

BMW

Sig by zeaq
witeshark is offline  
#5 (permalink) Old 05-03-2009, 12:23 PM
n00b
 
Join Date: May 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeroen_e34 is on a distinguished road
(Thread Starter)
No, engine and DME are all original.
Problem developed as intermittent first. sometimes it would develop full revs. But it is a constant problems since a couple of weeks.
I have noticed the following however.
The car smells to petrol when idling cold.
There is a very small coolant leak from the thermostat. There is some green residue near the crank sensor.

Rgds

Jeroen
jeroen_e34 is offline  
#6 (permalink) Old 05-03-2009, 12:26 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
I'm thinking that the residue around the crank sensor may be interfering with its reading.

BMW

Sig by zeaq
witeshark is offline  
#7 (permalink) Old 05-03-2009, 12:37 PM
n00b
 
Join Date: May 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeroen_e34 is on a distinguished road
(Thread Starter)
Cleaned the sensor, problem NOT solved. Still the same. No residue at the flywheel either.
Rgds

Jeroen
jeroen_e34 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
e34 540 running like pig TUF540 5-Series (E12,E28, E34, E39, E60) 4 05-08-2009 08:26 PM
E34 540 running bad jeroen_e34 New Members Check In 2 05-03-2009 01:32 PM
E34 525TD running very rough rolli 5-Series (E12,E28, E34, E39, E60) 0 04-26-2008 07:57 PM
E34 535i / 540 bigpetefromscunny 5-Series (E12,E28, E34, E39, E60) 1 05-28-2005 09:40 PM
E34 Running Ruff HI OFCR 5-Series (E12,E28, E34, E39, E60) 4 04-27-2005 06:33 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome