Door Lock Issue - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-07-2004, 09:45 PM
n00b
 
Join Date: Nov 2004
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RIPN RAY is an unknown quantity at this point
(Thread Starter)
so every time that i lock my doors on my 93 525i i have to do it twice. when i turn the key clockwise the first time it'll lock the doors and then unlock them right away. then when i do it a second time they'll stay locked. any ideas on what the problem is?


also the drivers door lock pin does not move when locked or unlock.

thanks
RIPN RAY is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-07-2004, 10:11 PM
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Posts: 14,878
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute
mine will do that in case im trying to lock a open door or something... never heard of the problem you are having.

Torque is offline  
#3 (permalink) Old 12-08-2004, 05:09 PM
2nd Gear Member
 
Join Date: Dec 2003
Location: California
Posts: 448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
frank3 is an unknown quantity at this point
I'm having the same problem on my 95 525i. I'm guessing that one of the actuators is a bit stuck and that the system automatically resets (unlocks) if the actuators don't lock all the doors. However once I've tried locking, this will kind of "unstick" the actuators and it will lock the second time (happens with either the key in the door or using my remote.

I probably need to sleuth out which actuator is sticking (I think mine is the front passenger door as well), not sure if this is something that can be greased, or if I need to replace the entire actuator.

<span style='color:green'>1994 325i </span>- - - 75,000 mi.
No mods - - - very happy as is!
<span style='color:green'>1995 525i </span>- - - 154,000 mi.
No squeaks or rattles... unreal!
frank3 is offline  
#4 (permalink) Old 01-12-2005, 11:59 AM
n00b
 
Join Date: Nov 2004
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RIPN RAY is an unknown quantity at this point
(Thread Starter)
found the problem!!

it's the trunk wiring around where the wires come off the hinge and on to the body. the wires flex a lot every time the trunk is opened and they brake and short out.

fixed it in 20 mins
RIPN RAY is offline  
#5 (permalink) Old 01-12-2005, 03:41 PM
2nd Gear Member
 
Join Date: Dec 2003
Location: California
Posts: 448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
frank3 is an unknown quantity at this point
Quote:
Originally posted by RIPN RAY@Jan 12 2005, 10:59 AM
found the problem!!

it's the trunk wiring around where the wires come off the hinge and on to the body. the wires flex a lot every time the trunk is opened and they brake and short out.

fixed it in 20 mins
[snapback]269831[/snapback]
What was the fix? Replace all the wiring?

<span style='color:green'>1994 325i </span>- - - 75,000 mi.
No mods - - - very happy as is!
<span style='color:green'>1995 525i </span>- - - 154,000 mi.
No squeaks or rattles... unreal!
frank3 is offline  
#6 (permalink) Old 01-12-2005, 04:12 PM
n00b
 
Join Date: Nov 2004
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RIPN RAY is an unknown quantity at this point
(Thread Starter)
i could've just put one but connector for each wire but that would've caused the same flexing and would've just come apart again.

instead i spliced in about 2-3 inches of wire with 2 butt connectors per broken wire. this way the butt connectors wouldn't be were the wire needed flexing for the opening and closing of trunk. instead the added wire would be there and do all the flexing.

i then zipped tied it together and put the harness back into place.

now that i'm rethinking it, it took longer then 20mins to do maybe 40. finding the broken wires was a pain. the harness is wrapped in tape and leaves a sticky residue. when unwrapping the harness start from the bottom inside the trunk. i had to remove the cd changer...that how far into the trunk that the wires break.

i'm still having problems with the interior trunk lights not working. if there's no power to the switch then i may check further up the harness to see if there are anymore breaks
RIPN RAY is offline  
#7 (permalink) Old 01-13-2005, 04:16 PM
2nd Gear Member
 
Join Date: Dec 2003
Location: California
Posts: 448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
frank3 is an unknown quantity at this point
Thanks...I'll give your fix a try. Still can't figure why the wires in the trunk trigger the front door locking problems...but if it fixed your's, it's worth a try!

<span style='color:green'>1994 325i </span>- - - 75,000 mi.
No mods - - - very happy as is!
<span style='color:green'>1995 525i </span>- - - 154,000 mi.
No squeaks or rattles... unreal!
frank3 is offline  
#8 (permalink) Old 01-13-2005, 04:22 PM
n00b
 
Join Date: Nov 2004
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RIPN RAY is an unknown quantity at this point
(Thread Starter)
well supposedly when the system malfunctions it will unlock the doors, but there is a back up this way you can't leave it unlocked.
RIPN RAY is offline  
#9 (permalink) Old 01-24-2005, 08:30 PM
da_administrator
 
da_bull's Avatar
 
Join Date: Jan 2005
Location: Mooooossouri
Posts: 4,840
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute da_bull has a reputation beyond repute
Send a message via MSN to da_bull
My 90 525i will do that if the trunk is unlocked. The car reminds you that the trunk is unlocked, the second time you lock the door it has told you and you are aware the trunk is unlocked and just want the doors locked. If you lock the trunk everything should be ok (as long as the wiring is correct) The E34s are notorious for that, mine hasnt done it yet, but I'm waiting...



-There are 10 kinds of people. Those who understand binary, and those who do not.

-If we ever forget that we are One Nation Under God, then we will be a nation gone under...Ronald Reagan
da_bull is offline  
#10 (permalink) Old 02-12-2009, 03:43 PM
n00b
 
Join Date: Jan 2009
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rollis is on a distinguished road
I'm getting similar problems except it's when I unlock the doors. When I unlock from either side it unlocks and immediately re-locks. I have to turn the key again and they will stayed unlocked. My drivers side stays locked, I have to open my back door and unlock from inside. When I lock the doors, the drivers side locks but it seems to go down slower than the others.
rollis is offline  
#11 (permalink) Old 02-13-2009, 06:17 PM
n00b
 
Pazz535i's Avatar
 
Join Date: Feb 2009
Location: Australia
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Pazz535i is on a distinguished road
Send a message via MSN to Pazz535i
Quote:
Originally Posted by da_bull View Post
My 90 525i will do that if the trunk is unlocked. The car reminds you that the trunk is unlocked, the second time you lock the door it has told you and you are aware the trunk is unlocked and just want the doors locked. If you lock the trunk everything should be ok (as long as the wiring is correct) The E34s are notorious for that, mine hasnt done it yet, but I'm waiting...
mine does this on occasion, and it took me ages to figure it out.
Like Da bull said it is infarct the boot being unlocked.
just remember to relocl the boot after you open it.. problem solved..

however i have the same problem with the boot light not staying on.. it will if the boot is opened to a certain angle.. and then go off if it moves up for down..
i have not solved this issue yet..

Love for the BMer


Pazz535i is offline  
#12 (permalink) Old 05-20-2009, 04:44 PM
n00b
 
Cam_uno's Avatar
 
Join Date: Feb 2009
Location: Rauma, Finland
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cam_uno is on a distinguished road
God I love this forum..... This was the info I needed and will start digging in tomorrow. Mine just started this have to lock it twice to keep it locked about 3 days ago and it's driving me ape shit. Today though, Locking or un-locking from the trunk quit working... So I guess we start ripping crap apart...

Side note....I was playing around with the drivers side door lock for giggles today and holy shit, how come nobody told me if you hold the key in the lock position that the sunroof and windows close.... I felt like a kid in the candy store and quite sure I looked like an ass out in the drive way playing with it....LMAO....what a tard...me anyone looking at me

"94" 518i Touring...What to do, what to do...
Cam_uno is offline  
#13 (permalink) Old 05-20-2009, 09:16 PM
n00b
 
Join Date: May 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
FastBMW123 is on a distinguished road
I almost guarantee that this is the problem with my car too. I have had to reconnect some of those wires in the past when one of my reverse lights went out and I also had some other wires that were broken in that bundle that I fixed, but I'm sure it's probably one of the remaining wires that I didn't already fix that broke.

FastBMW123 is offline  
#14 (permalink) Old 05-25-2009, 03:04 PM
n00b
 
Cam_uno's Avatar
 
Join Date: Feb 2009
Location: Rauma, Finland
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cam_uno is on a distinguished road
Well....It wasn't the wiring in the tailgate, although I did fix 6 wires in there and to my surprise....My glass opens the way it should now and my rear wiper actually behaves now. I'm not ruling out wiring, tho I'm starting to lean towards the passenger side actuator.

"94" 518i Touring...What to do, what to do...
Cam_uno is offline  
#15 (permalink) Old 05-25-2009, 03:14 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,698
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Best of luck sorting it!

BMW

Sig by zeaq
witeshark is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Issue? pamato 5-Series (E12,E28, E34, E39, E60) 9 10-27-2005 03:32 PM
Tiptronic issue - 325i 2003 freetodd24 3-Series (E46, E90) 1 10-14-2005 02:48 PM
Any Issue For Putting Obd I M3 Engine In 325i? r6bruin 3-Series (E36) 2 08-13-2005 07:12 AM
Bumper/bodywork/scratchpad Issue RokleM 3-Series (E46, E90) 4 08-04-2005 04:47 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome