Disappearing Pixels on dash display. - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-07-2006, 04:34 PM   #1 (permalink)
n00b
 
Join Date: Apr 2006
Location: Midland, GA
Car: 97 540i For sale
Posts: 13
Photos:
Jakers is on a distinguished road
Disappearing Pixels on dash display.

We bought a 540i back in the spring with 97,000 miles. The piwel displayed just below the tach and speedo are disappearing. It is a challenge to make out the mileage. I had heard a few references to the fact that BMWNA will rpelace the part but not the labor to install. Just before we bought this car we had the local BMW dealer do a "Pre-purchase Inspection". The pixel display was one of the issues on the inspection. I will have to look back at that inspection, but I am just about positive that they listed the part and labor to fix the display. The part was around $600-$700.

What do I need to do to get BMWNA to replace the part? Is this a job that I can do if I get my hands on the part? I give myself 3 1/2 wrenches out of a possible 5 wrenches.
Jakers is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-08-2006, 09:26 AM   #2 (permalink)
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Car: 97 540IA, 95 840CI
Posts: 863
Photos:
LOS is an unknown quantity at this point
Jakers,
Do a search under "pixels", "dashboard"... We have covered this many times. The unit you're talking about is a little more difficult to replace but can be done if you take your time. I had mine done at the dealer for around $400.
Check www.BMRPARTS.com or call them. They may have a unit in stock.
Also, as a reference check www.realoem.com It shows you how to assemble/disassemble parts & their part numbers.

LOS
LOS is offline   Reply With Quote
Old 08-12-2006, 02:40 AM   #3 (permalink)
5th Gear Member
 
CosmosBlack's Avatar
 
Join Date: Jul 2003
Location: Florida
Car: 2002 Porsche C4S
Posts: 1,282
Photos:
CosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond repute
Jakers: Write her a nice email - Leonora.Vlaovich@bmwna.com

At 97kmiles, they might not do it for you.
I was at 70kplus when they did mine parts free. I paid an hour's labor.
Good Luck!
__________________
CosmosBlack is offline   Reply With Quote
Old 08-12-2006, 08:51 AM   #4 (permalink)
3rd Gear Member
 
Scarface's Avatar
 
Join Date: May 2003
Location: Jacksonville, AL
Car:
Posts: 569
Photos:
Scarface is an unknown quantity at this point
Send a message via AIM to Scarface
Heck yeah thanks for the email, I sent her a very nice sweet email because I have the same problem!
__________________
-1998 BMW 540i6(Axis Penta 20's,M5 shadow grilles,trunk lip,led tails,oem front lip,PIAA lighting)
-2002 Cadillac Escalade(Zinik Luina 22's,OEM HID upgrade)
Scarface is offline   Reply With Quote
Old 08-14-2006, 01:26 AM   #5 (permalink)
5th Gear Member
 
CosmosBlack's Avatar
 
Join Date: Jul 2003
Location: Florida
Car: 2002 Porsche C4S
Posts: 1,282
Photos:
CosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond reputeCosmosBlack has a reputation beyond repute
Quote:
Originally Posted by Scarface
Heck yeah thanks for the email, I sent her a very nice sweet email because I have the same problem!
Good Luck, let us know how it goes for you.
__________________
CosmosBlack is offline   Reply With Quote
Old 04-17-2008, 12:20 AM   #6 (permalink)
n00b
 
Join Date: Apr 2006
Location: Midland, GA
Car: 97 540i For sale
Posts: 13
Photos:
Jakers is on a distinguished road
Quote:
Originally Posted by CosmosBlack View Post
Jakers: Write her a nice email - Leonora.Vlaovich@bmwna.com

At 97kmiles, they might not do it for you.
I was at 70kplus when they did mine parts free. I paid an hour's labor.
Good Luck!
Been off the forum for awhile.... As an update BMW fixed mine. I paid labor of about $90!
Jakers is offline   Reply With Quote
Old 05-14-2008, 09:23 PM   #7 (permalink)
n00b
 
Join Date: May 2008
Car:
Posts: 11
Photos:
Spinn is on a distinguished road
Quote:
Originally Posted by Jakers View Post
Been off the forum for awhile.... As an update BMW fixed mine. I paid labor of about $90!
I just emailed her. This is causing the BMW 540i that I just purchased to fail Maryland State inspection....estimate to fix....$820.
Spinn is offline   Reply With Quote
Old 10-04-2008, 01:34 PM   #8 (permalink)
n00b
 
Join Date: Oct 2008
Location: California
Car: 2002 530i
Posts: 7
Photos:
Lovelydama is on a distinguished road
My 2002 530i has same problem. Does there need to be a specific reason for BMWNA to fix it, or is it just a defect? I've got 105k on it... Don't want to spend $850 if I don't need to...
Lovelydama is offline   Reply With Quote
Old 10-04-2008, 01:45 PM   #9 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Hi, Here is a fix and it works:

PIXEL FIX DIY write up, about a 2 hour job and some patience (Long pic warning)

Although its for a 7 the 5 cluster is the same.

Please note: you do this at your own risk, ive done it , now been 1 1/2 years and still perfect.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 10-04-2008, 04:19 PM   #10 (permalink)
n00b
 
Join Date: Oct 2008
Location: California
Car: 2002 530i
Posts: 7
Photos:
Lovelydama is on a distinguished road
Thanks marti5 but unfortunately, i'm not experienced enough to do that. I'd most likely end up messing it up. I can do minor stuff but i think that's above me
Lovelydama is offline   Reply With Quote
Old 10-04-2008, 06:05 PM   #11 (permalink)
n00b
 
primejoist's Avatar
 
Join Date: Jan 2004
Location: Santa Cruz Mountains, CA
Car: 2000 540is
Posts: 5
Photos:
primejoist is an unknown quantity at this point
Disappearing pixels

Hello all - I'm new here.

Like many of you I found out that there is a bulletin out on the disappearing pixel issue. I had 103k on my 2000 540is and the dealer (Concord BMW) installed a new one asking only for 2 hr labor.
primejoist is offline   Reply With Quote
Old 10-05-2008, 06:07 AM   #12 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Quote:
Originally Posted by primejoist View Post
Hello all - I'm new here.

Like many of you I found out that there is a bulletin out on the disappearing pixel issue. I had 103k on my 2000 540is and the dealer (Concord BMW) installed a new one asking only for 2 hr labor.
Wow!!!!! 2 hrs labour, to change and reprogramme takes 1/2 an hour, what a rip off.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 10-05-2008, 04:18 PM   #13 (permalink)
n00b
 
Join Date: Oct 2008
Location: California
Car: 2002 530i
Posts: 7
Photos:
Lovelydama is on a distinguished road
Quote:
Originally Posted by primejoist View Post
Hello all - I'm new here.

Like many of you I found out that there is a bulletin out on the disappearing pixel issue. I had 103k on my 2000 540is and the dealer (Concord BMW) installed a new one asking only for 2 hr labor.
primejoist - where is this bulletin? i never heard of it...
Lovelydama is offline   Reply With Quote
Old 10-06-2008, 09:57 AM   #14 (permalink)
n00b
 
tAgC's Avatar
 
Join Date: Apr 2006
Location: South Africa
Car: 97 540i
Posts: 39
Photos:
tAgC is on a distinguished road
Send a message via Skype™ to tAgC
Thanks marti5 for posting the link and thanks to edwin for the writeup. I got about 95% of my pixels back I can read the temp on my 540 again
tAgC is offline   Reply With Quote
Old 10-06-2008, 06:55 PM   #15 (permalink)
n00b
 
Join Date: Oct 2008
Location: California
Car: 2002 530i
Posts: 7
Photos:
Lovelydama is on a distinguished road
I just contacted BMWNA. Hope this works....
Lovelydama is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Digital speed Il_Simo 3-Series (E36) 58 05-04-2006 05:47 AM
Screen Pixels WardJ 1,6,7,8 - Series and Mini Cooper 2 01-02-2006 12:03 AM
New Dash Passatie 3-Series (E36) 5 12-06-2005 08:11 PM
Dash Mods Advice wanted.... Nutted318 3-Series (E21, E30) 0 07-31-2004 08:21 PM
Center Console and Dash board Display 725tds 1,6,7,8 - Series and Mini Cooper 2 04-09-2004 07:45 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:39 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.