Code reads "cylinder 4 missfire" - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-21-2004, 10:54 PM
n00b
 
Join Date: Jun 2004
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bmw528i is an unknown quantity at this point
(Thread Starter)
Thumbs up

Hello all, this is my first time posting. I just recently bought a 1997 528i and this last week the check engine light came on, so I went to Autozone and had them read the code and it said the cylinder four is missing. I do notice that when I first start the car in the morning that it idles rough (misses) but after it warms up (within a couple of minutes) it stops missing. It only misses on start up and then smoothens out. There was one time that it was really cold in the morning and it missed all the way to work. But that was just once. I just recently replaced the spark plugs with Bosch Platinum plus fours but besides that and an oil change I have done nothing to the car. I have no maintanence records so I don't know when the last tune up was done.

If anyone could give me some advice with my troubles then I would greatly appreciate it.

Thank you,
Kevin
Bmw528i is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-21-2004, 11:25 PM
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Posts: 14,878
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute Torque has a reputation beyond repute
I know that this will sound dumb, but the best solution is to take it to a certified bmw dealer... unless of course you are a mechanic yourself and want to just chop the thing apart and see whats wrong.

Torque is offline  
#3 (permalink) Old 06-22-2004, 12:42 AM
1st Gear Member
 
Join Date: Apr 2004
Location: New Zealand
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silverlea is an unknown quantity at this point
If the new plugs havent fixed the problem,then it is quite possibly one of the sparkplug leads failing. Try throwing in a complete new set.Often a faulty lead will miss when cold,then come rite once car is warmed to running temperature.
Hope this helps.

Silverlea.
silverlea is offline  
#4 (permalink) Old 06-22-2004, 09:19 PM
n00b
 
Join Date: Jun 2004
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bmw528i is an unknown quantity at this point
(Thread Starter)
torque, I am kind of a mechanic so I could take it apart if I wanted, But I don't want to if I don't have to and I'm not quite familiar with the whole BMW thing yet.

Silverlea, Sounds like a possible solution because I notice the car doesn't blow any white smoke so the head gasket is fine, the only other solutions are that I have a bad valve, a bad injector or bad spark plug lead.

Thanks everyone for their replies, any more input feel free

Kevin
Bmw528i is offline  
#5 (permalink) Old 06-23-2004, 08:25 PM
n00b
 
Join Date: May 2003
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kowached is an unknown quantity at this point
Kevin, many including myself have had VERY bad experiences with those plugs, below are some examples. Best of luck.

Spark Plugs - Inspection II
OE stock Bosch or NGK, NOT Bosch +4's
There has been more than person that has discovered that their Bosch +4's have "backed out" or worse yet that some or all of the electrodes were actually missing from the plug. I myself found Bosch +4's finger tight after 10,000 miles and I know I torqued them to spec.


http://bimmer.roadfly.org/bmw/forums/e39/f...?postid=3031210

Message Title: Still no fix yet. My valve covers are leaking and

Posted by: Saman on 2003-04-14 at 14:17:53
(posted from: Host: IP: 159.178.203.36)
Message: couple of the spark plugs were drenched in oil. By the way, the Platinum 4 all 8 of them the tiny electrode had dissapeared completely, like it had vaporized. Put a set of the Bosch coppers from the dealership and the car is not missing any more. However, the power is not like what it used to be. I've gotten a catalytic efficiency a code a couple of times. I am thinking that, I might have
messed up the cats by dumping fuel in them when the car was missing for some time. Once I get the valve cover fixed tomorrow. I'm chaning out the O2 sensors since they are stock and the car has 110K and see what happens.

http://bimmer.roadfly.org/bmw/forums/e39/a...p?postid=223607

Message Title: My bad 540i weird idle solved

Posted by: Mike on 2001-12-14 at 13:00:06
(posted from: Host: wwwgate32.motorola.com IP: 136.182.2.222)
Message: Hi All, just wanted to send this warning out. I had the same weird idle problem as Ken S. and used some techroline to get rid of it. But it didn't. I took it to BMW and they said no codes set customer using BOSCH platinum +4, not recommended. Bosch recommended them when I put them in but just to see I put the old plugs back in and it doesn't miss a beat. Thought all of you would like to know not to buy these plugs.

http://bimmer.roadfly.org/bmw/forums/e39/a...p?postid=237174

Message Title: Re: My 97 540/6 is same. Sometimes nearly stalls at

Posted by: Mike on 2001-12-19 at 09:48:11
(posted from: Host: wwwgate35.motorola.com IP: 136.182.2.225)
Message: I complained to my dealer, they check the codes, none and told me to get the Bosch Plat +4 out, no recommended. Replaced them with the Bosch as F7 LDCR and my small idle problem is gone. I have a 98 540i 6 speed, hope this helps.

Later,
Dave

E39 - 1998 540iA Sport (11/97 Production)
E30 - 1989 M3 (44k miles)
1979 Triumph TR7, still have my first car ;-)
Past cars:
E21 - 1980 320i (sold at 130k)
E23 - 1986 735i
I am a BMW Car Club of America member, are you? <a href='http://www.bmwcca.org/' target='_blank'>http://www.bmwcca.org/</a>
<img src='http://members.roadfly.com/kowached/bmwcca1.gif' border='0' alt='user posted image'>
kowached is offline  
#6 (permalink) Old 06-25-2004, 01:53 PM
n00b
 
Join Date: Jun 2004
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bmw528i is an unknown quantity at this point
(Thread Starter)
OH that sounds bad, except luckily it had this idle problem before I put in the +4's so I know it's not related to that, but I will keep my eye on that. I purchased new leads and a new development in problems happened. I smell coolant, and when I accelerate fairly hard when it's still cold I see a lot of smoke "poof out of the back of the car" Still trying to figure out wether the smoke is more blue or white, seems white because it evaporates quick into the air and doesn't linger. This also tells me that I may have a bad head gasket...DOH!!!

Kevin
Bmw528i is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E30 Anti-theft Radio Code aaronhoy 3-Series (E21, E30) 4 06-08-2009 11:40 AM
Strange Fault Code ben_t 5-Series (E12,E28, E34, E39, E60) 0 04-02-2005 06:53 AM
Dwa/ews Input Peake Fault Code? jday 5-Series (E12,E28, E34, E39, E60) 8 02-04-2005 09:19 AM
Asking For Code jshearer Audio and Electronics 1 12-18-2004 08:28 PM
stereo/radio anti-theft code xristo 3-Series (E21, E30) 3 03-02-2004 04:18 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome